summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-04-25 05:17:59 +0000
committerHans de Graaff <graaff@gentoo.org>2014-04-25 05:17:59 +0000
commitb5ded0f2b54ab041e8bbcd466dfc037d5f0adc11 (patch)
tree96f1a2bda717b1cb343a7b3b5c36b76a3676452c /dev-ruby/rjb
parentcreate a loader script for msfconsole to handle the bundler Gemfile hacks, mi... (diff)
downloadgentoo-2-b5ded0f2b54ab041e8bbcd466dfc037d5f0adc11.tar.gz
gentoo-2-b5ded0f2b54ab041e8bbcd466dfc037d5f0adc11.tar.bz2
gentoo-2-b5ded0f2b54ab041e8bbcd466dfc037d5f0adc11.zip
Cleanup.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/rjb')
-rw-r--r--dev-ruby/rjb/ChangeLog7
-rw-r--r--dev-ruby/rjb/rjb-1.4.5.ebuild61
2 files changed, 5 insertions, 63 deletions
diff --git a/dev-ruby/rjb/ChangeLog b/dev-ruby/rjb/ChangeLog
index fb1f5732e9ed..3e629dccd6d1 100644
--- a/dev-ruby/rjb/ChangeLog
+++ b/dev-ruby/rjb/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/rjb
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rjb/ChangeLog,v 1.2 2013/12/22 15:42:14 mrueg Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rjb/ChangeLog,v 1.3 2014/04/25 05:17:59 graaff Exp $
+
+ 25 Apr 2014; Hans de Graaff <graaff@gentoo.org> -rjb-1.4.5.ebuild:
+ Cleanup.
*rjb-1.4.8 (22 Dec 2013)
diff --git a/dev-ruby/rjb/rjb-1.4.5.ebuild b/dev-ruby/rjb/rjb-1.4.5.ebuild
deleted file mode 100644
index a86d0a8e0fdb..000000000000
--- a/dev-ruby/rjb/rjb-1.4.5.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rjb/rjb-1.4.5.ebuild,v 1.1 2013/12/15 16:41:32 zerochaos Exp $
-
-EAPI=5
-
-USE_RUBY="ruby19"
-
-RUBY_FAKEGEM_EXTRADOC="readme.txt ChangeLog"
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_TASK_TEST=""
-
-inherit java-pkg-2 ruby-ng ruby-fakegem
-
-DESCRIPTION="Rjb is a Ruby-Java software bridge"
-HOMEPAGE="http://rjb.rubyforge.org/"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples hardened"
-
-DEPEND=">=virtual/jdk-1.5
- hardened? ( sys-apps/paxctl )"
-RDEPEND="virtual/jre"
-
-pkg_setup() {
- ruby-ng_pkg_setup
- java-pkg-2_pkg_setup
-}
-
-each_ruby_prepare() {
- #dev-lang/ruby might need the "hardened" flag to enforce the following:
- if use hardened; then
- paxctl -v /usr/bin/ruby 2>/dev/null | grep MPROTECT | grep disabled || ewarn '!!! rjb may only work if ruby is MPROTECT disabled, but not really sure\n please disable it if required using paxctl -m /usr/bin/ruby'
- fi
- # force compilation of class file for our JVM
- rm -rf data
-}
-
-each_ruby_configure() {
- ${RUBY} -C ext extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
- emake -C ext CFLAGS="${CFLAGS} -fPIC" archflags="${LDFLAGS}" || die "emake failed"
-}
-
-each_ruby_install() {
- each_fakegem_install
-
- # currently no elegant way to do this (bug #352765)
- ruby_fakegem_newins ext/rjbcore.so lib/rjbcore.so
-
- ruby_fakegem_doins -r data
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r samples || die "installing samples failed"
- fi
-}