summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-02-23 16:12:37 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-02-23 16:12:37 +0000
commitc20e67c24eb40a4f86816302f119d9adc273085b (patch)
tree533852dc7729256ab5220c2112514c24f00c122d /dev-ruby/rspec-mocks
parentamd64 stable, bug #501344 (diff)
downloadgentoo-2-c20e67c24eb40a4f86816302f119d9adc273085b.tar.gz
gentoo-2-c20e67c24eb40a4f86816302f119d9adc273085b.tar.bz2
gentoo-2-c20e67c24eb40a4f86816302f119d9adc273085b.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/rspec-mocks')
-rw-r--r--dev-ruby/rspec-mocks/ChangeLog7
-rw-r--r--dev-ruby/rspec-mocks/rspec-mocks-2.14.6.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-ruby/rspec-mocks/ChangeLog b/dev-ruby/rspec-mocks/ChangeLog
index c5259085b596..316078d4f50f 100644
--- a/dev-ruby/rspec-mocks/ChangeLog
+++ b/dev-ruby/rspec-mocks/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rspec-mocks
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-mocks/ChangeLog,v 1.62 2014/02/04 23:52:08 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-mocks/ChangeLog,v 1.63 2014/02/23 16:12:37 mrueg Exp $
+
+*rspec-mocks-2.14.6 (23 Feb 2014)
+
+ 23 Feb 2014; Manuel Rüger <mrueg@gentoo.org> +rspec-mocks-2.14.6.ebuild:
+ Version bump.
*rspec-mocks-2.14.5 (04 Feb 2014)
diff --git a/dev-ruby/rspec-mocks/rspec-mocks-2.14.6.ebuild b/dev-ruby/rspec-mocks/rspec-mocks-2.14.6.ebuild
new file mode 100644
index 000000000000..76336a0b4e1e
--- /dev/null
+++ b/dev-ruby/rspec-mocks/rspec-mocks-2.14.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-mocks/rspec-mocks-2.14.6.ebuild,v 1.1 2014/02/23 16:12:37 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ruby20 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="http://rspec.rubyforge.org/"
+SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/rspec-core-2.10.0:2
+ dev-ruby/rspec-expectations:2
+ )"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Remove the Gemfile to avoid running through 'bundle exec'
+ rm Gemfile || die
+
+ # Remove .rspec options to avoid dependency on newer rspec when
+ # bootstrapping.
+ rm .rspec || die
+}