summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-13 16:38:15 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-13 16:38:15 +0000
commit4fe44259d4b5dd24a1038f4a699c5eb52b860be0 (patch)
treea2029a4f2c435cee4fafa4ea8dcda2d7ae8369d3 /dev-ruby/rspec-rails
parentMarking zentest-4.2.1 ~ppc64 for bug 298367 (diff)
downloadgentoo-2-4fe44259d4b5dd24a1038f4a699c5eb52b860be0.tar.gz
gentoo-2-4fe44259d4b5dd24a1038f4a699c5eb52b860be0.tar.bz2
gentoo-2-4fe44259d4b5dd24a1038f4a699c5eb52b860be0.zip
Version bump.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rspec-rails')
-rw-r--r--dev-ruby/rspec-rails/ChangeLog8
-rw-r--r--dev-ruby/rspec-rails/rspec-rails-1.3.2.ebuild34
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-ruby/rspec-rails/ChangeLog b/dev-ruby/rspec-rails/ChangeLog
index c37365493c79..77f180a95789 100644
--- a/dev-ruby/rspec-rails/ChangeLog
+++ b/dev-ruby/rspec-rails/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rspec-rails
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-rails/ChangeLog,v 1.23 2010/01/12 16:39:05 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-rails/ChangeLog,v 1.24 2010/01/13 16:38:15 flameeyes Exp $
+
+*rspec-rails-1.3.2 (13 Jan 2010)
+
+ 13 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +rspec-rails-1.3.2.ebuild:
+ Version bump.
*rspec-rails-1.3.1 (12 Jan 2010)
diff --git a/dev-ruby/rspec-rails/rspec-rails-1.3.2.ebuild b/dev-ruby/rspec-rails/rspec-rails-1.3.2.ebuild
new file mode 100644
index 000000000000..8e98f1372a15
--- /dev/null
+++ b/dev-ruby/rspec-rails/rspec-rails-1.3.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-rails/rspec-rails-1.3.2.ebuild,v 1.1 2010/01/13 16:38:15 flameeyes Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18"
+
+# would be spec, but it needs to be in the same filesystem tree as
+# rspec (and cannot use the install-reduced code), so we cannot run
+# them for now.
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="Contribute.rdoc History.rdoc README.rdoc Upgrade.rdoc TODO.txt"
+
+RUBY_FAKEGEM_EXTRAINSTALL="generators"
+
+inherit ruby-fakegem
+
+DESCRIPTION="RSpec's official Ruby on Rails plugin"
+HOMEPAGE="http://rspec.info/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/rspec-1.3.0 >=dev-ruby/rack-1.0.0"
+
+# Without this the whole Rakefile fails, so it's a general dependency
+# and not just a test dependency.
+ruby_add_bdepend doc dev-util/cucumber