summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-12-27 18:42:26 +0000
committerHans de Graaff <graaff@gentoo.org>2010-12-27 18:42:26 +0000
commit6f0c4a4c592d0f76ef8225d9c9711846b9692960 (patch)
tree43c12ab0539edfec9fe1960483062c88d24b045c /dev-ruby/rspec
parentStable for HPPA PPC (bug #349567). (diff)
downloadgentoo-2-6f0c4a4c592d0f76ef8225d9c9711846b9692960.tar.gz
gentoo-2-6f0c4a4c592d0f76ef8225d9c9711846b9692960.tar.bz2
gentoo-2-6f0c4a4c592d0f76ef8225d9c9711846b9692960.zip
Remove old versions.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rspec')
-rw-r--r--dev-ruby/rspec/ChangeLog6
-rw-r--r--dev-ruby/rspec/rspec-1.3.0-r1.ebuild68
-rw-r--r--dev-ruby/rspec/rspec-1.3.0.ebuild68
3 files changed, 5 insertions, 137 deletions
diff --git a/dev-ruby/rspec/ChangeLog b/dev-ruby/rspec/ChangeLog
index 04a026ddf1a9..a851650048b4 100644
--- a/dev-ruby/rspec/ChangeLog
+++ b/dev-ruby/rspec/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/rspec
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/ChangeLog,v 1.82 2010/12/03 18:05:18 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/ChangeLog,v 1.83 2010/12/27 18:42:26 graaff Exp $
+
+ 27 Dec 2010; Hans de Graaff <graaff@gentoo.org> -rspec-1.3.0.ebuild,
+ -rspec-1.3.0-r1.ebuild:
+ Remove old versions.
02 Dec 2010; Fabian Groffen <grobian@gentoo.org> rspec-1.3.1.ebuild,
rspec-2.0.0_beta22.ebuild:
diff --git a/dev-ruby/rspec/rspec-1.3.0-r1.ebuild b/dev-ruby/rspec/rspec-1.3.0-r1.ebuild
deleted file mode 100644
index 15d2f88d823d..000000000000
--- a/dev-ruby/rspec/rspec-1.3.0-r1.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/rspec-1.3.0-r1.ebuild,v 1.2 2010/10/25 02:08:46 jer Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ree18 ruby19 jruby"
-
-RUBY_FAKEGEM_TASK_TEST="spec"
-
-RUBY_FAKEGEM_TASK_DOC="docs"
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc TODO.txt Ruby1.9.rdoc Upgrade.rdoc"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
-HOMEPAGE="http://rspec.rubyforge.org/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
-IUSE=""
-
-# it's actually optional, but tests fail if it's not installed and
-# some other package might fail tests, so require it anyway.
-ruby_add_rdepend dev-ruby/diff-lcs
-
-ruby_add_bdepend "doc? ( dev-ruby/hoe )"
-
-RDEPEND="!<dev-ruby/rspec-rails-${PV}"
-
-# don't require test dependencies for jruby since we cannot run them
-# for now (fakefs doesn't work).
-#
-# We should add nokogiri here to make sure that we test as much as
-# possible, but since it's yet unported to 1.9 and the nokogiri-due
-# tests fail for sure, we'll be waiting on it.
-USE_RUBY="ruby18 ree18 ruby19" \
- ruby_add_bdepend "test? ( dev-ruby/hoe dev-ruby/zentest dev-ruby/fakefs )"
-
-# the testsuite skips over heckle for Ruby 1.9 so we only request it for 1.8
-USE_RUBY="ruby18 ree18" \
- ruby_add_bdepend "test? ( dev-ruby/heckle )"
-
-all_ruby_prepare() {
- # Replace reference to /tmp to our temporary directory to avoid
- # sandbox-related failure.
- sed -i \
- -e "s:/tmp:${T}:" \
- spec/spec/runner/command_line_spec.rb || die
-}
-
-src_test() {
- chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
- ruby-ng_src_test
-}
-
-each_ruby_test() {
- case ${RUBY} in
- *jruby)
- ewarn "Tests for JRuby are disabled because dev-ruby/fakefs does not currently support"
- ewarn "JRuby properly and it's needed to run the tests."
- ;;
- *)
- each_fakegem_test
- ;;
- esac
-}
diff --git a/dev-ruby/rspec/rspec-1.3.0.ebuild b/dev-ruby/rspec/rspec-1.3.0.ebuild
deleted file mode 100644
index 8496455fdf53..000000000000
--- a/dev-ruby/rspec/rspec-1.3.0.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/rspec-1.3.0.ebuild,v 1.12 2010/09/07 13:25:44 flameeyes Exp $
-
-EAPI=2
-USE_RUBY="ruby18 jruby"
-
-RUBY_FAKEGEM_TASK_TEST="spec"
-
-RUBY_FAKEGEM_TASK_DOC="docs"
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc TODO.txt Ruby1.9.rdoc Upgrade.rdoc"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
-HOMEPAGE="http://rspec.rubyforge.org/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
-IUSE=""
-
-# it's actually optional, but tests fail if it's not installed and
-# some other package might fail tests, so require it anyway.
-ruby_add_rdepend dev-ruby/diff-lcs
-
-ruby_add_bdepend "doc? ( dev-ruby/hoe )"
-
-RDEPEND="!<dev-ruby/rspec-rails-${PV}"
-
-# don't require test dependencies for jruby since we cannot run them
-# for now (fakefs doesn't work).
-#
-# We should add nokogiri here to make sure that we test as much as
-# possible, but since it's yet unported to 1.9 and the nokogiri-due
-# tests fail for sure, we'll be waiting on it.
-USE_RUBY="ruby18 ruby19" \
- ruby_add_bdepend "test? ( dev-ruby/hoe dev-ruby/zentest dev-ruby/fakefs )"
-
-# the testsuite skips over heckle for Ruby 1.9 so we only request it for 1.8
-USE_RUBY="ruby18" \
- ruby_add_bdepend "test? ( dev-ruby/heckle )"
-
-all_ruby_prepare() {
- # Replace reference to /tmp to our temporary directory to avoid
- # sandbox-related failure.
- sed -i \
- -e "s:/tmp:${T}:" \
- spec/spec/runner/command_line_spec.rb || die
-}
-
-src_test() {
- chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
- ruby-ng_src_test
-}
-
-each_ruby_test() {
- case ${RUBY} in
- *jruby)
- ewarn "Tests for JRuby are disabled because dev-ruby/fakefs does not currently support"
- ewarn "JRuby properly and it's needed to run the tests."
- ;;
- *)
- each_fakegem_test
- ;;
- esac
-}