summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-07-29 00:06:52 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-07-29 00:06:52 +0000
commit989d6e1e007fe54ea9bd57a0ad21413321de8877 (patch)
treea3888ebe0589a00a47cad9381538169478cac879 /dev-ruby/rspec
parentFix running tests on Ruby 1.9.2 (bug #330209), remove useless sed, cleanup ol... (diff)
downloadgentoo-2-989d6e1e007fe54ea9bd57a0ad21413321de8877.tar.gz
gentoo-2-989d6e1e007fe54ea9bd57a0ad21413321de8877.tar.bz2
gentoo-2-989d6e1e007fe54ea9bd57a0ad21413321de8877.zip
Add dependency over diff-lcs (bug #329495, bug #330207); fix the $HOME permissions (bug #299367).
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rspec')
-rw-r--r--dev-ruby/rspec/ChangeLog6
-rw-r--r--dev-ruby/rspec/rspec-1.3.0.ebuild14
2 files changed, 14 insertions, 6 deletions
diff --git a/dev-ruby/rspec/ChangeLog b/dev-ruby/rspec/ChangeLog
index 27f616d312bf..0b983a5bf36c 100644
--- a/dev-ruby/rspec/ChangeLog
+++ b/dev-ruby/rspec/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/rspec
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/ChangeLog,v 1.72 2010/07/21 12:50:18 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/ChangeLog,v 1.73 2010/07/29 00:06:52 flameeyes Exp $
+
+ 29 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org> rspec-1.3.0.ebuild:
+ Add dependency over diff-lcs (bug #329495, bug #330207); fix the $HOME
+ permissions (bug #299367).
21 Jul 2010; Christian Faulhammer <fauli@gentoo.org>
rspec-1.2.9-r1.ebuild:
diff --git a/dev-ruby/rspec/rspec-1.3.0.ebuild b/dev-ruby/rspec/rspec-1.3.0.ebuild
index 89f2a0c82f9b..a58e949740ea 100644
--- a/dev-ruby/rspec/rspec-1.3.0.ebuild
+++ b/dev-ruby/rspec/rspec-1.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/rspec-1.3.0.ebuild,v 1.9 2010/05/22 23:18:57 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/rspec-1.3.0.ebuild,v 1.10 2010/07/29 00:06:52 flameeyes Exp $
EAPI=2
USE_RUBY="ruby18 ree18 ruby19 jruby"
@@ -21,7 +21,11 @@ SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
IUSE=""
-ruby_add_bdepend doc dev-ruby/hoe
+# it's actually optional, but tests fail if it's not installed and
+# some other package might fail tests, so require it anyway.
+ruby_add_rdepend dev-ruby/diff-lcs
+
+ruby_add_bdepend "doc? ( dev-ruby/hoe )"
RDEPEND="!<dev-ruby/rspec-rails-${PV}"
@@ -32,11 +36,11 @@ RDEPEND="!<dev-ruby/rspec-rails-${PV}"
# possible, but since it's yet unported to 1.9 and the nokogiri-due
# tests fail for sure, we'll be waiting on it.
USE_RUBY="ruby18 ree18 ruby19" \
- ruby_add_bdepend test "dev-ruby/hoe dev-ruby/zentest dev-ruby/fakefs"
+ ruby_add_bdepend "test? ( dev-ruby/hoe dev-ruby/zentest dev-ruby/fakefs )"
# the testsuite skips over heckle for Ruby 1.9 so we only request it for 1.8
USE_RUBY="ruby18 ree18" \
- ruby_add_bdepend test "dev-ruby/heckle"
+ ruby_add_bdepend "test? ( dev-ruby/heckle )"
all_ruby_prepare() {
# Replace reference to /tmp to our temporary directory to avoid
@@ -47,7 +51,7 @@ all_ruby_prepare() {
}
src_test() {
- chmod 0755 ${WORKDIR/work/homedir} || die "Failed to fix permissions on home"
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
ruby-ng_src_test
}