summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-02-01 10:51:20 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-02-01 10:51:20 +0000
commit0920eca93f4dd1905200123e668a02210bfb382d (patch)
tree762ce3155d1b9c166bee41270465d04c39d53e3b /dev-ruby/ruby-fcgi
parentCopy texmf files after make install so that we do not get out of date files, ... (diff)
downloadgentoo-2-0920eca93f4dd1905200123e668a02210bfb382d.tar.gz
gentoo-2-0920eca93f4dd1905200123e668a02210bfb382d.tar.bz2
gentoo-2-0920eca93f4dd1905200123e668a02210bfb382d.zip
Bump to fakegem and use a newer, forked version that works on Ruby 1.9.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/ruby-fcgi')
-rw-r--r--dev-ruby/ruby-fcgi/ChangeLog8
-rw-r--r--dev-ruby/ruby-fcgi/ruby-fcgi-0.8.9.ebuild53
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-ruby/ruby-fcgi/ChangeLog b/dev-ruby/ruby-fcgi/ChangeLog
index 4342cccaa7d3..83eecc64755e 100644
--- a/dev-ruby/ruby-fcgi/ChangeLog
+++ b/dev-ruby/ruby-fcgi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/ruby-fcgi
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-fcgi/ChangeLog,v 1.30 2010/01/04 11:55:11 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-fcgi/ChangeLog,v 1.31 2010/02/01 10:51:20 flameeyes Exp $
+
+*ruby-fcgi-0.8.9 (01 Feb 2010)
+
+ 01 Feb 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +ruby-fcgi-0.8.9.ebuild:
+ Bump to fakegem and use a newer, forked version that works on Ruby 1.9.
04 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
ruby-fcgi-0.8.7-r2.ebuild:
diff --git a/dev-ruby/ruby-fcgi/ruby-fcgi-0.8.9.ebuild b/dev-ruby/ruby-fcgi/ruby-fcgi-0.8.9.ebuild
new file mode 100644
index 000000000000..c15b6037ccf0
--- /dev/null
+++ b/dev-ruby/ruby-fcgi/ruby-fcgi-0.8.9.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-fcgi/ruby-fcgi-0.8.9.ebuild,v 1.1 2010/02/01 10:51:20 flameeyes Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_TASK_DOC="rdoc"
+
+# there are not tests, the only file is a moot fake file
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README README.signals ChangeLog"
+
+inherit ruby-fakegem
+
+DESCRIPTION="FastCGI library for Ruby. Forked version."
+HOMEPAGE="http://github.com/saks/fcgi"
+
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+LICENSE="Ruby"
+
+DEPEND="dev-libs/fcgi"
+RDEPEND="${DEPEND}"
+
+IUSE=""
+SLOT="0"
+
+each_ruby_compile() {
+ pushd ext/fcgi
+ ${RUBY} extconf.rb || die "extconf failed"
+ emake || die "emake ext failed"
+ popd
+}
+
+each_ruby_install() {
+ each_fakegem_install
+
+ ruby_fakegem_newins ext/fcgi/fcgi.so lib/fcgi.so
+}
+
+pkg_postinst() {
+ elog "Starting from ruby-fcgi-0.8.9 the dev-ruby/ruby-fcgi package installs"
+ elog "the ruby-fcgi gem rather than the previous fcgi gem."
+ elog "This is a forked version that is compatible with Ruby 1.9 and provides"
+ elog "proper documentation infrastructure that we can make use of."
+ elog ""
+ elog "If you have any reason to prefer the original fcgi gem, you should"
+ elog "let us know on the bugzilla (http://bugs.gentoo.org/) and we'll see"
+ elog "to add the other gem as an alternative."
+}