summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-08-21 20:08:15 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-08-21 20:08:15 +0000
commit79f6ae5ede0f767ae9ecf56665a41f303bef9a1a (patch)
treeed4f355627a65ccf59e3250e3d2c51e5d83243c5 /dev-ruby/ruby-fcgi
parentRemove unused files (diff)
downloadgentoo-2-79f6ae5ede0f767ae9ecf56665a41f303bef9a1a.tar.gz
gentoo-2-79f6ae5ede0f767ae9ecf56665a41f303bef9a1a.tar.bz2
gentoo-2-79f6ae5ede0f767ae9ecf56665a41f303bef9a1a.zip
Remove unused file and prepare a revision with Ruby 1.9 so 0.8.8 can be stabilized.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/ruby-fcgi')
-rw-r--r--dev-ruby/ruby-fcgi/ChangeLog10
-rw-r--r--dev-ruby/ruby-fcgi/files/ruby-fcgi-0.8.7-19compat.patch78
-rw-r--r--dev-ruby/ruby-fcgi/ruby-fcgi-0.8.8-r1.ebuild39
-rw-r--r--dev-ruby/ruby-fcgi/ruby-fcgi-0.8.8.ebuild4
4 files changed, 50 insertions, 81 deletions
diff --git a/dev-ruby/ruby-fcgi/ChangeLog b/dev-ruby/ruby-fcgi/ChangeLog
index d7292658baf7..9150c4ca38d0 100644
--- a/dev-ruby/ruby-fcgi/ChangeLog
+++ b/dev-ruby/ruby-fcgi/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-ruby/ruby-fcgi
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-fcgi/ChangeLog,v 1.36 2010/05/22 20:13:34 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-fcgi/ChangeLog,v 1.37 2010/08/21 20:08:14 flameeyes Exp $
+
+*ruby-fcgi-0.8.8-r1 (21 Aug 2010)
+
+ 21 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ -files/ruby-fcgi-0.8.7-19compat.patch, ruby-fcgi-0.8.8.ebuild,
+ +ruby-fcgi-0.8.8-r1.ebuild:
+ Remove unused file and prepare a revision with Ruby 1.9 so 0.8.8 can be
+ stabilized.
22 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
-ruby-fcgi-0.8.7-r2.ebuild, -ruby-fcgi-0.8.7-r3.ebuild:
diff --git a/dev-ruby/ruby-fcgi/files/ruby-fcgi-0.8.7-19compat.patch b/dev-ruby/ruby-fcgi/files/ruby-fcgi-0.8.7-19compat.patch
deleted file mode 100644
index c444fa05742b..000000000000
--- a/dev-ruby/ruby-fcgi/files/ruby-fcgi-0.8.7-19compat.patch
+++ /dev/null
@@ -1,78 +0,0 @@
-Patch for Ruby 1.9 compatibility, backport from upstream SVN.
-
---- ext/fcgi/fcgi.c 2006-06-25 06:06:42.000000000 +0200
-+++ ext/fcgi/fcgi.c.r47 2008-12-02 10:37:47.000000000 +0100
-@@ -17,6 +17,16 @@
- #include "fcgiapp.h"
- #endif
-
-+#ifndef RARRAY_PTR
-+#define RARRAY_LEN(ary) (RARRAY(ary)->len)
-+#define RARRAY_PTR(ary) (RARRAY(ary)->ptr)
-+#endif
-+
-+#ifndef RSTRING_PTR
-+#define RSTRING_LEN(str) (RSTRING(str)->len)
-+#define RSTRING_PTR(str) (RSTRING(str)->ptr)
-+#endif
-+
- static VALUE cFCGI;
- static VALUE eFCGIError;
- static VALUE cFCGIStream;
-@@ -222,7 +232,7 @@
- rb_secure(4);
- Data_Get_Struct(self, FCGX_Stream, stream);
- str = rb_obj_as_string(str);
-- len = FCGX_PutStr(RSTRING(str)->ptr, RSTRING(str)->len, stream);
-+ len = FCGX_PutStr(RSTRING_PTR(str), RSTRING_LEN(str), stream);
- if (len == EOF) CHECK_STREAM_ERROR(stream);
- return INT2NUM(len);
- }
-@@ -271,8 +281,8 @@
- VALUE tmp;
- int i;
-
-- for (i=0; i<RARRAY(ary)->len; i++) {
-- tmp = RARRAY(ary)->ptr[i];
-+ for (i=0; i<RARRAY_LEN(ary); i++) {
-+ tmp = RARRAY_PTR(ary)[i];
- if (rb_inspecting_p(tmp)) {
- tmp = rb_str_new2("[...]");
- }
-@@ -305,7 +315,7 @@
- }
- line = rb_obj_as_string(line);
- fcgi_stream_write(out, line);
-- if (RSTRING(line)->ptr[RSTRING(line)->len-1] != '\n') {
-+ if (RSTRING_PTR(line)[RSTRING_LEN(line)-1] != '\n') {
- fcgi_stream_write(out, rb_default_rs);
- }
- }
-@@ -379,7 +389,7 @@
- rb_str_cat(str, buff, strlen(buff));
- if (strchr(buff, '\n')) break;
- }
-- if (RSTRING(str)->len > 0)
-+ if (RSTRING_LEN(str) > 0)
- return str;
- else
- return Qnil;
-@@ -507,7 +517,8 @@
-
-
-
--void Init_fcgi() {
-+void Init_fcgi()
-+{
-
- FCGX_Init();
-
-@@ -517,7 +528,7 @@
- rb_define_singleton_method(cFCGI, "each", fcgi_s_each, 0);
- rb_define_singleton_method(cFCGI, "each_request", fcgi_s_each, 0);
- rb_define_singleton_method(cFCGI, "is_cgi?", fcgi_s_iscgi, 0);
-- rb_define_method(cFCGI, "in", fcgi_in, 0);
-+ rb_define_method(cFCGI, "in", fcgi_in, 0);
- rb_define_method(cFCGI, "out", fcgi_out, 0);
- rb_define_method(cFCGI, "err", fcgi_err, 0);
- rb_define_method(cFCGI, "env", fcgi_env, 0);
diff --git a/dev-ruby/ruby-fcgi/ruby-fcgi-0.8.8-r1.ebuild b/dev-ruby/ruby-fcgi/ruby-fcgi-0.8.8-r1.ebuild
new file mode 100644
index 000000000000..2a78767623dc
--- /dev/null
+++ b/dev-ruby/ruby-fcgi/ruby-fcgi-0.8.8-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-fcgi/ruby-fcgi-0.8.8-r1.ebuild,v 1.1 2010/08/21 20:08:15 flameeyes Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_NAME="${PN/ruby-/}"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README README.signals ChangeLog"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="FastCGI library for Ruby"
+HOMEPAGE="http://rubyforge.org/projects/fcgi/"
+
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+LICENSE="Ruby"
+
+DEPEND="dev-libs/fcgi"
+RDEPEND="${DEPEND}"
+
+IUSE=""
+SLOT="0"
+
+each_ruby_compile() {
+ case ${RUBY} in
+ *ruby18)
+ pushd ext/fcgi
+ ${RUBY} extconf.rb || die "extconf failed"
+ emake || die "emake ext failed"
+ popd
+ cp ext/fcgi/fcgi.so lib || die
+ ;;
+ esac
+}
diff --git a/dev-ruby/ruby-fcgi/ruby-fcgi-0.8.8.ebuild b/dev-ruby/ruby-fcgi/ruby-fcgi-0.8.8.ebuild
index 56be3a54408e..ad6bb9886965 100644
--- a/dev-ruby/ruby-fcgi/ruby-fcgi-0.8.8.ebuild
+++ b/dev-ruby/ruby-fcgi/ruby-fcgi-0.8.8.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-fcgi/ruby-fcgi-0.8.8.ebuild,v 1.1 2010/05/03 05:39:03 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-fcgi/ruby-fcgi-0.8.8.ebuild,v 1.2 2010/08/21 20:08:15 flameeyes Exp $
EAPI=2
-USE_RUBY="ruby18 ruby19 jruby"
+USE_RUBY="ruby18 jruby"
RUBY_FAKEGEM_NAME="${PN/ruby-/}"