summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-04-24 08:04:05 +0000
committerHans de Graaff <graaff@gentoo.org>2011-04-24 08:04:05 +0000
commitdbb09cc5da734a2751718f3ea0c574e641e695fc (patch)
tree9745573f29c6b85a215447df10d59daf4604863b /dev-ruby/ruby-prof
parentadd note that citadel is from sunrise (diff)
downloadgentoo-2-dbb09cc5da734a2751718f3ea0c574e641e695fc.tar.gz
gentoo-2-dbb09cc5da734a2751718f3ea0c574e641e695fc.tar.bz2
gentoo-2-dbb09cc5da734a2751718f3ea0c574e641e695fc.zip
Version bump.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/ruby-prof')
-rw-r--r--dev-ruby/ruby-prof/ChangeLog9
-rw-r--r--dev-ruby/ruby-prof/ruby-prof-0.10.2.ebuild76
2 files changed, 83 insertions, 2 deletions
diff --git a/dev-ruby/ruby-prof/ChangeLog b/dev-ruby/ruby-prof/ChangeLog
index 982db5553962..1bd0697dcbd2 100644
--- a/dev-ruby/ruby-prof/ChangeLog
+++ b/dev-ruby/ruby-prof/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/ruby-prof
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ChangeLog,v 1.29 2010/09/19 12:55:10 graaff Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ChangeLog,v 1.30 2011/04/24 08:04:05 graaff Exp $
+
+*ruby-prof-0.10.2 (24 Apr 2011)
+
+ 24 Apr 2011; Hans de Graaff <graaff@gentoo.org> +ruby-prof-0.10.2.ebuild:
+ Version bump.
*ruby-prof-0.9.2 (19 Sep 2010)
diff --git a/dev-ruby/ruby-prof/ruby-prof-0.10.2.ebuild b/dev-ruby/ruby-prof/ruby-prof-0.10.2.ebuild
new file mode 100644
index 000000000000..b0db3c1a78e7
--- /dev/null
+++ b/dev-ruby/ruby-prof/ruby-prof-0.10.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ruby-prof-0.10.2.ebuild,v 1.1 2011/04/24 08:04:05 graaff Exp $
+
+EAPI=3
+
+# jruby → not compatible, since it uses an extension, but there is a bug
+# open for it: https://github.com/rdp/ruby-prof/issues/36
+# ree18 fails tests, not reported yet.
+
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc CHANGES"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A module for profiling Ruby code"
+HOMEPAGE="https://github.com/rdp/ruby-prof"
+SRC_URI="https://github.com/rdp/${PN}/tarball/${PV} -> ${P}.tgz"
+S="${WORKDIR}/rdp-${PN}-*"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
+
+all_ruby_prepare() {
+ # The thread testing in 0.8.1 and earlier versions is broken, it
+ # has to be tested for the next versions, since upstream is
+ # looking for a solution. The problem is that it's _very_
+ # timing-dependent.
+# rm "${S}"/test/thread_test.rb \
+# || die "unable to remove broken test unit"
+# sed -i -e '/thread_test/d' \
+# test/test_suite.rb || die "unable to remove broken test reference"
+
+ # We install the shared object in lib, not ext.
+ sed -i -e 's#../ext/ruby_prof#../lib/ruby_prof#' lib/ruby-prof.rb
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *ruby19)
+ # On ruby 1.9 this test fails badly, so we disable it
+ # until upstream can fix the related bug:
+ # http://redmine.ruby-lang.org/issues/show/2012
+ sed -i -e '/^ def test_flat_string_with_numbers/,/^ end/ s:^:#:' \
+ test/printers_test.rb || die "Unable to disable test_flat_string_with_numbers"
+ ;;
+ esac
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/ruby_prof extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ # gem ships with prebuild files
+ emake -Cext/ruby_prof clean || die "clean failed"
+ emake -Cext/ruby_prof || die "build failed"
+
+ mkdir lib/ruby_prof || die "unable to create directory for shared object"
+ cp ext/ruby_prof/*$(get_modname) lib/ruby_prof || die "copy of extension failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ for dir in examples rails rails/example rails/environment; do
+ docinto "$dir"
+ dodoc "$dir"/* || die "dodoc $dir failed"
+ done
+}