summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-02-23 16:24:48 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-02-23 16:24:48 +0000
commitcc6149a78031f0cf4557442d37f1140c6de35d46 (patch)
treec2e31e7f703ed7a6ad75c0389f6a8b986fe13e8b /dev-ruby/ruby_parser
parentVersion bump. Add ruby21 target. (diff)
downloadgentoo-2-cc6149a78031f0cf4557442d37f1140c6de35d46.tar.gz
gentoo-2-cc6149a78031f0cf4557442d37f1140c6de35d46.tar.bz2
gentoo-2-cc6149a78031f0cf4557442d37f1140c6de35d46.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/ruby_parser')
-rw-r--r--dev-ruby/ruby_parser/ChangeLog9
-rw-r--r--dev-ruby/ruby_parser/ruby_parser-3.4.1.ebuild45
2 files changed, 52 insertions, 2 deletions
diff --git a/dev-ruby/ruby_parser/ChangeLog b/dev-ruby/ruby_parser/ChangeLog
index d493317749b2..36e607c89820 100644
--- a/dev-ruby/ruby_parser/ChangeLog
+++ b/dev-ruby/ruby_parser/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/ruby_parser
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby_parser/ChangeLog,v 1.56 2013/12/19 23:46:29 mrueg Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby_parser/ChangeLog,v 1.57 2014/02/23 16:24:48 mrueg Exp $
+
+*ruby_parser-3.4.1 (23 Feb 2014)
+
+ 23 Feb 2014; Manuel Rüger <mrueg@gentoo.org> +ruby_parser-3.4.1.ebuild:
+ Version bump.
19 Dec 2013; Manuel Rüger <mrueg@gentoo.org> -ruby_parser-2.0.5.ebuild,
-ruby_parser-3.2.2.ebuild:
diff --git a/dev-ruby/ruby_parser/ruby_parser-3.4.1.ebuild b/dev-ruby/ruby_parser/ruby_parser-3.4.1.ebuild
new file mode 100644
index 000000000000..4663b253b08b
--- /dev/null
+++ b/dev-ruby/ruby_parser/ruby_parser-3.4.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby_parser/ruby_parser-3.4.1.ebuild,v 1.1 2014/02/23 16:24:48 mrueg Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19 ruby20 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A ruby parser written in pure ruby."
+HOMEPAGE="https://github.com/seattlerb/ruby_parser"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/sexp_processor-4.1:4
+ !<dev-ruby/ruby_parser-2.3.1-r1"
+
+ruby_add_bdepend "doc? ( >=dev-ruby/hoe-2.9.1 )"
+ruby_add_bdepend "test? ( >=dev-ruby/minitest-4.3 )"
+
+all_ruby_prepare() {
+ # Remove reference to perforce method that is not in a released
+ # version of hoe-seattlerb.
+ #sed -i -e '/perforce/d' Rakefile || die
+ sed -i -e '/license/d' Rakefile || die
+ sed -i -e '/Hoe.plugin :isolate/ s:^:#:' Rakefile || die
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *jruby)
+ # Disable tests failing on jruby related to //n regexp
+ # https://github.com/seattlerb/ruby_parser/issues/117
+ rm test/test_ruby_parser.rb || die
+ ;;
+ esac
+}