summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-05-02 11:25:35 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-05-02 11:25:35 +0000
commitf2ddb14d7500699b079a5779da1193b99da422c2 (patch)
tree99e235ff40b36636b49b022a3f2e03858761ae71 /dev-ruby/storable
parentVarious improvements to the ebuild by Toffanin [Gentoo/FreeBSD AT] <toffanin.... (diff)
downloadgentoo-2-f2ddb14d7500699b079a5779da1193b99da422c2.tar.gz
gentoo-2-f2ddb14d7500699b079a5779da1193b99da422c2.tar.bz2
gentoo-2-f2ddb14d7500699b079a5779da1193b99da422c2.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/storable')
-rw-r--r--dev-ruby/storable/ChangeLog8
-rw-r--r--dev-ruby/storable/storable-0.7.4.ebuild43
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-ruby/storable/ChangeLog b/dev-ruby/storable/ChangeLog
index a6150018f575..c1de65928527 100644
--- a/dev-ruby/storable/ChangeLog
+++ b/dev-ruby/storable/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/storable
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/storable/ChangeLog,v 1.10 2010/05/01 00:51:31 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/storable/ChangeLog,v 1.11 2010/05/02 11:25:35 flameeyes Exp $
+
+*storable-0.7.4 (02 May 2010)
+
+ 02 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +storable-0.7.4.ebuild:
+ Version bump.
01 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
storable-0.7.3.ebuild:
diff --git a/dev-ruby/storable/storable-0.7.4.ebuild b/dev-ruby/storable/storable-0.7.4.ebuild
new file mode 100644
index 000000000000..f9109d111a0f
--- /dev/null
+++ b/dev-ruby/storable/storable-0.7.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/storable/storable-0.7.4.ebuild,v 1.1 2010/05/02 11:25:35 flameeyes Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Marshal Ruby classes into and out of multiple formats"
+HOMEPAGE="http://solutious.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+SRC_URI="http://github.com/delano/${PN}/tarball/v${PV} -> ${PN}-git-${PV}.tgz"
+S="${WORKDIR}/delano-${PN}-*"
+
+ruby_add_bdepend test dev-ruby/tryouts
+
+all_ruby_prepare() {
+ mv bin examples || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -S sergeant || die "tests failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/* || die
+}