summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-12-13 00:58:33 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-12-13 00:58:33 +0000
commit2958cb5c10da195466381e50ee6330a07d030277 (patch)
tree0c2e19cb00e825d34047a1fb883df7bcf1332e1c /dev-ruby/temple
parentVersion bump. (diff)
downloadgentoo-2-2958cb5c10da195466381e50ee6330a07d030277.tar.gz
gentoo-2-2958cb5c10da195466381e50ee6330a07d030277.tar.bz2
gentoo-2-2958cb5c10da195466381e50ee6330a07d030277.zip
Add ruby20 target.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/temple')
-rw-r--r--dev-ruby/temple/ChangeLog7
-rw-r--r--dev-ruby/temple/temple-0.6.7-r1.ebuild27
2 files changed, 33 insertions, 1 deletions
diff --git a/dev-ruby/temple/ChangeLog b/dev-ruby/temple/ChangeLog
index 75a25e0e297a..74f756fd3e90 100644
--- a/dev-ruby/temple/ChangeLog
+++ b/dev-ruby/temple/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/temple
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/temple/ChangeLog,v 1.13 2013/11/11 10:32:29 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/temple/ChangeLog,v 1.14 2013/12/13 00:58:33 mrueg Exp $
+
+*temple-0.6.7-r1 (13 Dec 2013)
+
+ 13 Dec 2013; Manuel Rüger <mrueg@gentoo.org> +temple-0.6.7-r1.ebuild:
+ Add ruby20 target.
11 Nov 2013; Manuel Rüger <mrueg@gentoo.org> -temple-0.5.5.ebuild,
-temple-0.6.6.ebuild:
diff --git a/dev-ruby/temple/temple-0.6.7-r1.ebuild b/dev-ruby/temple/temple-0.6.7-r1.ebuild
new file mode 100644
index 000000000000..637a6e393c46
--- /dev/null
+++ b/dev-ruby/temple/temple-0.6.7-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/temple/temple-0.6.7-r1.ebuild,v 1.1 2013/12/13 00:58:33 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES EXPRESSIONS.md README.md"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="An abstraction and a framework for compiling templates to pure Ruby."
+HOMEPAGE="http://github.com/judofyr/temple"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/bacon dev-ruby/tilt )"
+
+each_ruby_test() {
+ ${RUBY} -S bacon -Ilib -Itest --automatic --quiet || die
+}