summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-07-14 07:12:52 +0000
committerHans de Graaff <graaff@gentoo.org>2012-07-14 07:12:52 +0000
commit1545e9e7fea526753ca206433ec36019b4029fb3 (patch)
treeb17602e90ff53302bfc3053715a9e79228faf5cd /dev-ruby/termcolor
parentformat metadata.xml (diff)
downloadgentoo-2-1545e9e7fea526753ca206433ec36019b4029fb3.tar.gz
gentoo-2-1545e9e7fea526753ca206433ec36019b4029fb3.tar.bz2
gentoo-2-1545e9e7fea526753ca206433ec36019b4029fb3.zip
Add upstream fix for failing spec.
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/termcolor')
-rw-r--r--dev-ruby/termcolor/ChangeLog6
-rw-r--r--dev-ruby/termcolor/files/termcolor-1.2.1-fix-spec.patch19
-rw-r--r--dev-ruby/termcolor/termcolor-1.2.1.ebuild4
3 files changed, 27 insertions, 2 deletions
diff --git a/dev-ruby/termcolor/ChangeLog b/dev-ruby/termcolor/ChangeLog
index e98e5471a51b..eabb5e9a12be 100644
--- a/dev-ruby/termcolor/ChangeLog
+++ b/dev-ruby/termcolor/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/termcolor
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/termcolor/ChangeLog,v 1.3 2012/07/08 21:46:13 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/termcolor/ChangeLog,v 1.4 2012/07/14 07:12:51 graaff Exp $
+
+ 14 Jul 2012; Hans de Graaff <graaff@gentoo.org> termcolor-1.2.1.ebuild,
+ +files/termcolor-1.2.1-fix-spec.patch:
+ Add upstream fix for failing spec.
*termcolor-1.2.1 (08 Jul 2012)
diff --git a/dev-ruby/termcolor/files/termcolor-1.2.1-fix-spec.patch b/dev-ruby/termcolor/files/termcolor-1.2.1-fix-spec.patch
new file mode 100644
index 000000000000..411f29dbf4e7
--- /dev/null
+++ b/dev-ruby/termcolor/files/termcolor-1.2.1-fix-spec.patch
@@ -0,0 +1,19 @@
+commit c455099b273c514c0ae8e5aad485be207a4e933c
+Author: jugyo <jugyo.org@gmail.com>
+Date: Mon Aug 30 23:59:04 2010 +0900
+
+ fixed spec
+
+diff --git a/spec/termcolor_spec.rb b/spec/termcolor_spec.rb
+index 888a13d..50d403c 100644
+--- a/spec/termcolor_spec.rb
++++ b/spec/termcolor_spec.rb
+@@ -27,7 +27,7 @@ module TermColor
+ it 'should parse 3' do
+ text = TermColor.parse('aa<30>bbbbbbb<32>cccc<90>ddd</90>c</32>b</30>aaa')
+ puts text
+- text.should == "aa\e[30mbbbbbbb\e[32mcccc\e[90mddd\e[0m\e[32mc\e[0m\e[30mb\e[0maaa"
++ text.should == "aa\e[30mbbbbbbb\e[32mcccc\e[90mddd\e[0m\e[30m\e[32mc\e[0m\e[30mb\e[0maaa"
+ end
+
+ it 'should parse 4' do
diff --git a/dev-ruby/termcolor/termcolor-1.2.1.ebuild b/dev-ruby/termcolor/termcolor-1.2.1.ebuild
index 7b5f5b449d0e..d96c6092dd68 100644
--- a/dev-ruby/termcolor/termcolor-1.2.1.ebuild
+++ b/dev-ruby/termcolor/termcolor-1.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/termcolor/termcolor-1.2.1.ebuild,v 1.1 2012/07/08 21:46:13 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/termcolor/termcolor-1.2.1.ebuild,v 1.2 2012/07/14 07:12:51 graaff Exp $
EAPI="2"
#*** Using highline effectively in JRuby requires manually installing the ffi-ncurses gem.
@@ -21,6 +21,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
+RUBY_PATCHES=( ${P}-fix-spec.patch )
+
ruby_add_bdepend "dev-ruby/rspec:0"
ruby_add_rdepend ">=dev-ruby/highline-1.5.0"