summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2010-08-31 20:14:24 +0000
committerAlex Legler <a3li@gentoo.org>2010-08-31 20:14:24 +0000
commit10ecfb491bcd4daac60a6de7d30d55fe87b40a92 (patch)
treeee9abc392855841a7ece77643777c994a2994ba0 /dev-ruby/thor
parentAdded forgotten dependency on dev-java/commons-codec (diff)
downloadgentoo-2-10ecfb491bcd4daac60a6de7d30d55fe87b40a92.tar.gz
gentoo-2-10ecfb491bcd4daac60a6de7d30d55fe87b40a92.tar.bz2
gentoo-2-10ecfb491bcd4daac60a6de7d30d55fe87b40a92.zip
Adding thor, needed by Rails 3. Ebuild by me.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/thor')
-rw-r--r--dev-ruby/thor/ChangeLog10
-rw-r--r--dev-ruby/thor/metadata.xml12
-rw-r--r--dev-ruby/thor/thor-0.14.0.ebuild44
3 files changed, 66 insertions, 0 deletions
diff --git a/dev-ruby/thor/ChangeLog b/dev-ruby/thor/ChangeLog
new file mode 100644
index 000000000000..0d19432b862f
--- /dev/null
+++ b/dev-ruby/thor/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ruby/thor
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/thor/ChangeLog,v 1.1 2010/08/31 20:14:24 a3li Exp $
+
+*thor-0.14.0 (31 Aug 2010)
+
+ 31 Aug 2010; Alex Legler <a3li@gentoo.org> +thor-0.14.0.ebuild,
+ +metadata.xml:
+ Initial import. Ebuild by me.
+
diff --git a/dev-ruby/thor/metadata.xml b/dev-ruby/thor/metadata.xml
new file mode 100644
index 000000000000..91b06d8e1eff
--- /dev/null
+++ b/dev-ruby/thor/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <longdescription>
+ Thor is a simple and efficient tool for building self-documenting
+ command line utilities. It removes the pain of parsing command line
+ options, writing "USAGE:" banners, and can also be used as an
+ alternative to the Rake build tool. The syntax is Rake-like, so it
+ should be familiar to most Rake users.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-ruby/thor/thor-0.14.0.ebuild b/dev-ruby/thor/thor-0.14.0.ebuild
new file mode 100644
index 000000000000..5916d1d95a69
--- /dev/null
+++ b/dev-ruby/thor/thor-0.14.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/thor/thor-0.14.0.ebuild,v 1.1 2010/08/31 20:14:24 a3li Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.md"
+RUBY_FAKEGEM_BINWRAP="thor"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A scripting framework that replaces rake and sake"
+HOMEPAGE="http://github.com/wycats/thor"
+
+SRC_URI="http://github.com/wycats/${PN}/tarball/v${PV} -> ${PN}-git-${PV}.tgz"
+S="${WORKDIR}/wycats-${PN}-4647c98"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+ruby_add_bdepend "
+ test? ( dev-ruby/fakeweb )
+ doc? ( dev-ruby/rdoc )"
+
+all_ruby_prepare() {
+ einfo $(pwd)
+ # Having VERSION in the docs makes the rdoc generation fail.
+ sed -i -e '/EXTRA_RDOC_FILES/s/"VERSION", //' Thorfile || die
+}
+
+all_ruby_compile() {
+ einfo $(pwd)
+ use doc && ruby -Ilib bin/thor rdoc || die "RDoc generation failed"
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib/ bin/thor spec || die "Tests for ${RUBY} failed"
+}