summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-12-28 08:15:56 +0000
committerHans de Graaff <graaff@gentoo.org>2011-12-28 08:15:56 +0000
commitf5920543beb04ae34b2f00376303ea53748dba82 (patch)
treebc30a2ea411e3557d186a49b0b76102fde8aa040 /dev-ruby/tmail
parentRevision bump to drop ruby19 from stable version. (diff)
downloadgentoo-2-f5920543beb04ae34b2f00376303ea53748dba82.tar.gz
gentoo-2-f5920543beb04ae34b2f00376303ea53748dba82.tar.bz2
gentoo-2-f5920543beb04ae34b2f00376303ea53748dba82.zip
Revision bump to drop ruby19 from stable version.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/tmail')
-rw-r--r--dev-ruby/tmail/ChangeLog8
-rw-r--r--dev-ruby/tmail/tmail-1.2.7.1-r2.ebuild4
-rw-r--r--dev-ruby/tmail/tmail-1.2.7.1-r3.ebuild70
3 files changed, 79 insertions, 3 deletions
diff --git a/dev-ruby/tmail/ChangeLog b/dev-ruby/tmail/ChangeLog
index 8b412a86db1e..d0c1a58982ce 100644
--- a/dev-ruby/tmail/ChangeLog
+++ b/dev-ruby/tmail/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/tmail
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tmail/ChangeLog,v 1.20 2011/07/24 17:41:07 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tmail/ChangeLog,v 1.21 2011/12/28 08:15:56 graaff Exp $
+
+*tmail-1.2.7.1-r3 (28 Dec 2011)
+
+ 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> tmail-1.2.7.1-r2.ebuild,
+ +tmail-1.2.7.1-r3.ebuild:
+ Revision bump to drop ruby19 from stable version.
24 Jul 2011; Raúl Porcel <armin76@gentoo.org> tmail-1.2.7.1-r2.ebuild:
ia64/sparc stable
diff --git a/dev-ruby/tmail/tmail-1.2.7.1-r2.ebuild b/dev-ruby/tmail/tmail-1.2.7.1-r2.ebuild
index 63ff10a27f4c..7561c6981c99 100644
--- a/dev-ruby/tmail/tmail-1.2.7.1-r2.ebuild
+++ b/dev-ruby/tmail/tmail-1.2.7.1-r2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tmail/tmail-1.2.7.1-r2.ebuild,v 1.7 2011/07/24 17:41:07 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tmail/tmail-1.2.7.1-r2.ebuild,v 1.8 2011/12/28 08:15:56 graaff Exp $
EAPI=2
-USE_RUBY="ruby18 ree18 ruby19 jruby"
+USE_RUBY="ruby18 ree18 jruby"
RUBY_FAKEGEM_TASK_DOC="doc"
RUBY_FAKEGEM_DOCDIR="doc"
diff --git a/dev-ruby/tmail/tmail-1.2.7.1-r3.ebuild b/dev-ruby/tmail/tmail-1.2.7.1-r3.ebuild
new file mode 100644
index 000000000000..67a411405f65
--- /dev/null
+++ b/dev-ruby/tmail/tmail-1.2.7.1-r3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tmail/tmail-1.2.7.1-r3.ebuild,v 1.1 2011/12/28 08:15:56 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README CHANGES NOTES"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An email handling library"
+HOMEPAGE="http://rubyforge.org/projects/tmail/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="debug"
+
+# Tests seem to be broken with the new encoding handling from Ruby,
+# need to be verified twice; code seems to work anyway.
+RESTRICT=test
+
+# Once it's added to portage, this should be added, right now it's
+# bundled.
+# ruby_add_rdepend dev-ruby/rchardet
+
+ruby_add_bdepend "
+ dev-ruby/racc
+ test? ( >=dev-ruby/mocha-0.9.5 )"
+
+all_ruby_prepare() {
+ # Provide file that is no longer distributed but still needed
+ mkdir meta || die "Failed to mkdir meta."
+ echo "tmail" > meta/unixname || die "Failed to create unixname file."
+}
+
+each_ruby_configure() {
+ case ${RUBY} in
+ *ruby18 | *rubyee18)
+ ${RUBY} -Cext/tmailscanner/tmail extconf.rb || die "extconf failed"
+ ;;
+ esac
+}
+
+each_ruby_compile() {
+ emake -C lib/tmail $(use debug && echo DEBUG=true) parser.rb || die "emake failed"
+
+ case ${RUBY} in
+ *ruby18 | *rubyee18)
+ emake -Cext/tmailscanner/tmail \
+ CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}" || die "emake extension failed"
+ ;;
+ esac
+}
+
+each_ruby_install() {
+ # We cannot use the recursive install because there are
+ # racc source files and a makefile.
+ find lib -name '*.rb' | while read file; do
+ ruby_fakegem_newins $file $file
+ done
+
+ [[ -f ext/tmailscanner/tmail/tmailscanner.so ]] && \
+ ruby_fakegem_newins ext/tmailscanner/tmail/tmailscanner.so lib/tmail/tmailscanner.so
+
+ ruby_fakegem_install_gemspec
+}