summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-11-05 19:29:14 +0000
committerHans de Graaff <graaff@gentoo.org>2013-11-05 19:29:14 +0000
commit0d53d81f2a73533a24ee72520fec79ca53833b98 (patch)
treec0d540984a288eaec7e33934f2259065cdf28e48 /dev-ruby/tzinfo
parentdrop old (diff)
downloadgentoo-2-0d53d81f2a73533a24ee72520fec79ca53833b98.tar.gz
gentoo-2-0d53d81f2a73533a24ee72520fec79ca53833b98.tar.bz2
gentoo-2-0d53d81f2a73533a24ee72520fec79ca53833b98.zip
Revision bump to add ruby20.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/tzinfo')
-rw-r--r--dev-ruby/tzinfo/ChangeLog7
-rw-r--r--dev-ruby/tzinfo/tzinfo-0.3.37-r1.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-ruby/tzinfo/ChangeLog b/dev-ruby/tzinfo/ChangeLog
index 619651a1f5a2..bdc93d3ce998 100644
--- a/dev-ruby/tzinfo/ChangeLog
+++ b/dev-ruby/tzinfo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/tzinfo
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/ChangeLog,v 1.121 2013/10/24 14:44:15 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/ChangeLog,v 1.122 2013/11/05 19:29:14 graaff Exp $
+
+*tzinfo-0.3.37-r1 (05 Nov 2013)
+
+ 05 Nov 2013; Hans de Graaff <graaff@gentoo.org> +tzinfo-0.3.37-r1.ebuild:
+ Revision bump to add ruby20.
24 Oct 2013; Tony Vroon <chainsaw@gentoo.org> tzinfo-0.3.37.ebuild:
Marked stable on AMD64 based on arch testing by Elijah "Armageddon" El
diff --git a/dev-ruby/tzinfo/tzinfo-0.3.37-r1.ebuild b/dev-ruby/tzinfo/tzinfo-0.3.37-r1.ebuild
new file mode 100644
index 000000000000..2b553a07bc0f
--- /dev/null
+++ b/dev-ruby/tzinfo/tzinfo-0.3.37-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/tzinfo-0.3.37-r1.ebuild,v 1.1 2013/11/05 19:29:14 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ruby20 jruby"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Daylight-savings aware timezone library"
+HOMEPAGE="http://tzinfo.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+all_ruby_prepare() {
+ # With rubygems 1.3.1 we get the following warning
+ # warning: Insecure world writable dir /var/tmp in LOAD_PATH, mode 041777
+ # when running the test_get_tainted_not_loaded test.
+ sed -i \
+ -e '/^ def test_get_tainted_not_loaded/, /^ end/ s:^:#:' \
+ "${S}"/test/tc_timezone.rb || die "unable to sed out the test"
+}
+
+each_ruby_test() {
+ TZ='America/Los_Angeles' ${RUBY} -I. -S testrb test/tc_*.rb || die
+}