summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-04-04 07:07:50 +0000
committerHans de Graaff <graaff@gentoo.org>2015-04-04 07:07:50 +0000
commit2706ee3b993063a2c19a37f4bf1b9e73c6ba590f (patch)
treea988d4024a723d2aef18d71c281442504ab633ac /dev-ruby/tzinfo
parentMake sure every build uses the same filesystem layout when installed #539092 ... (diff)
downloadgentoo-2-2706ee3b993063a2c19a37f4bf1b9e73c6ba590f.tar.gz
gentoo-2-2706ee3b993063a2c19a37f4bf1b9e73c6ba590f.tar.bz2
gentoo-2-2706ee3b993063a2c19a37f4bf1b9e73c6ba590f.zip
Create stable candidate.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/tzinfo')
-rw-r--r--dev-ruby/tzinfo/ChangeLog8
-rw-r--r--dev-ruby/tzinfo/tzinfo-0.3.43-r1.ebuild36
-rw-r--r--dev-ruby/tzinfo/tzinfo-0.3.43.ebuild4
3 files changed, 45 insertions, 3 deletions
diff --git a/dev-ruby/tzinfo/ChangeLog b/dev-ruby/tzinfo/ChangeLog
index 244958c9affe..052852257510 100644
--- a/dev-ruby/tzinfo/ChangeLog
+++ b/dev-ruby/tzinfo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/tzinfo
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/ChangeLog,v 1.142 2015/04/04 07:06:17 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/ChangeLog,v 1.143 2015/04/04 07:07:50 graaff Exp $
+
+*tzinfo-0.3.43-r1 (04 Apr 2015)
+
+ 04 Apr 2015; Hans de Graaff <graaff@gentoo.org> tzinfo-0.3.43.ebuild,
+ +tzinfo-0.3.43-r1.ebuild:
+ Create stable candidate.
04 Apr 2015; Hans de Graaff <graaff@gentoo.org> -tzinfo-0.3.38.ebuild:
Cleanup.
diff --git a/dev-ruby/tzinfo/tzinfo-0.3.43-r1.ebuild b/dev-ruby/tzinfo/tzinfo-0.3.43-r1.ebuild
new file mode 100644
index 000000000000..ad17cf648718
--- /dev/null
+++ b/dev-ruby/tzinfo/tzinfo-0.3.43-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/tzinfo-0.3.43-r1.ebuild,v 1.1 2015/04/04 07:07:50 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Daylight-savings aware timezone library"
+HOMEPAGE="http://tzinfo.github.io/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+all_ruby_prepare() {
+ # With rubygems 1.3.1 we get the following warning
+ # warning: Insecure world writable dir /var/tmp in LOAD_PATH, mode 041777
+ # when running the test_get_tainted_not_loaded test.
+ sed -i \
+ -e '/^ def test_get_tainted_not_loaded/, /^ end/ s:^:#:' \
+ "${S}"/test/tc_timezone.rb || die "unable to sed out the test"
+}
+
+each_ruby_test() {
+ TZ='America/Los_Angeles' ${RUBY} -I. -S testrb test/tc_*.rb || die
+}
diff --git a/dev-ruby/tzinfo/tzinfo-0.3.43.ebuild b/dev-ruby/tzinfo/tzinfo-0.3.43.ebuild
index 84cce381243a..a7e405d09ab2 100644
--- a/dev-ruby/tzinfo/tzinfo-0.3.43.ebuild
+++ b/dev-ruby/tzinfo/tzinfo-0.3.43.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/tzinfo-0.3.43.ebuild,v 1.1 2015/02/27 10:28:57 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/tzinfo-0.3.43.ebuild,v 1.2 2015/04/04 07:07:50 graaff Exp $
EAPI=5
-USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+USE_RUBY="ruby19 ruby20"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_DOCDIR="doc"