summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-14 17:36:27 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-14 17:36:27 +0000
commit397dc29e445b658c5a88386613feae132e29ab69 (patch)
tree528dc3cc74f1c1b6fdd8546138ceca243d3be709 /dev-ruby/unf
parentStable ppc ppc64, bug #430152 (diff)
downloadgentoo-2-397dc29e445b658c5a88386613feae132e29ab69.tar.gz
gentoo-2-397dc29e445b658c5a88386613feae132e29ab69.tar.bz2
gentoo-2-397dc29e445b658c5a88386613feae132e29ab69.zip
Make sure to install the gemspec, but fix it so that it works correctly with JRuby.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/unf')
-rw-r--r--dev-ruby/unf/ChangeLog9
-rw-r--r--dev-ruby/unf/unf-0.0.5-r1.ebuild57
-rw-r--r--dev-ruby/unf/unf-0.0.5.ebuild38
3 files changed, 65 insertions, 39 deletions
diff --git a/dev-ruby/unf/ChangeLog b/dev-ruby/unf/ChangeLog
index f31501fba924..f07448ee77e0 100644
--- a/dev-ruby/unf/ChangeLog
+++ b/dev-ruby/unf/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/unf
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/unf/ChangeLog,v 1.2 2012/08/14 16:58:13 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/unf/ChangeLog,v 1.3 2012/08/14 17:36:27 flameeyes Exp $
+
+*unf-0.0.5-r1 (14 Aug 2012)
+
+ 14 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org> +unf-0.0.5-r1.ebuild,
+ -unf-0.0.5.ebuild:
+ Make sure to install the gemspec, but fix it so that it works correctly with
+ JRuby.
14 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org> unf-0.0.5.ebuild:
Disable test task (drops rake dependency for USE=test); use Test::Unit 2 and
diff --git a/dev-ruby/unf/unf-0.0.5-r1.ebuild b/dev-ruby/unf/unf-0.0.5-r1.ebuild
new file mode 100644
index 000000000000..09687f12ce36
--- /dev/null
+++ b/dev-ruby/unf/unf-0.0.5-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/unf/unf-0.0.5-r1.ebuild,v 1.1 2012/08/14 17:36:27 flameeyes Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A wrapper library to bring Unicode Normalization Form support to Ruby/JRuby."
+HOMEPAGE="https://github.com/knu/ruby-unf"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+# jruby already has support for UNF so it does not need the extension.
+USE_RUBY=${USE_RUBY/jruby/} ruby_add_rdepend "dev-ruby/unf_ext"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/test-unit-2.5.1-r1
+ dev-ruby/shoulda
+ )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/,/end/ d' test/helper.rb || die
+
+ # Remove development dependencies; also remove platform as we don't
+ # care about it as it is, they only use it to avoid the unf_ext dep
+ # that we tackle on our own; finally remove git ls-files usage.
+ sed -i -e '/dependency.*\(shoulda\|bundler\|jeweler\|rcov\)/d' \
+ -e '/platform/d' \
+ -e '/git ls/d' \
+ ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_prepare() {
+ if [[ ${RUBY} == *jruby ]]; then
+ # Remove dependency over unf_ext which does not exist for JRuby
+ # remove platform, we don't set it.
+ sed -i -e '/dependency.*unf_ext/d' \
+ ${RUBY_FAKEGEM_GEMSPEC} || die
+ fi
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 test/test_*.rb
+}
diff --git a/dev-ruby/unf/unf-0.0.5.ebuild b/dev-ruby/unf/unf-0.0.5.ebuild
deleted file mode 100644
index 01e5f5c04dce..000000000000
--- a/dev-ruby/unf/unf-0.0.5.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/unf/unf-0.0.5.ebuild,v 1.2 2012/08/14 16:58:13 flameeyes Exp $
-
-EAPI=4
-
-USE_RUBY="ruby18 ruby19 ree18 jruby"
-
-RUBY_FAKEGEM_RECIPE_TEST="none"
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A wrapper library to bring Unicode Normalization Form support to Ruby/JRuby."
-HOMEPAGE="https://github.com/knu/ruby-unf"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-
-# jruby already has support for UNF so it does not need the extension.
-USE_RUBY=${USE_RUBY/jruby/} ruby_add_rdepend "dev-ruby/unf_ext"
-
-ruby_add_bdepend "
- test? (
- >=dev-ruby/test-unit-2.5.1-r1
- dev-ruby/shoulda
- )"
-
-all_ruby_prepare() {
- sed -i -e '/bundler/,/end/ s:^:#:' test/helper.rb || die
-}
-
-each_ruby_test() {
- ruby-ng_testrb-2 test/test_*.rb
-}