summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-08-17 08:40:09 +0000
committerHans de Graaff <graaff@gentoo.org>2011-08-17 08:40:09 +0000
commit0ab92bc732d853f0b2028164064622e4688c045b (patch)
treecdb4a4aaaf1d96b277b056c8c1bf99ea9a813c70 /dev-ruby
parentVersion bump. (diff)
downloadgentoo-2-0ab92bc732d853f0b2028164064622e4688c045b.tar.gz
gentoo-2-0ab92bc732d853f0b2028164064622e4688c045b.tar.bz2
gentoo-2-0ab92bc732d853f0b2028164064622e4688c045b.zip
Version bump.
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/activeresource/ChangeLog8
-rw-r--r--dev-ruby/activeresource/activeresource-2.3.14.ebuild34
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-ruby/activeresource/ChangeLog b/dev-ruby/activeresource/ChangeLog
index effc87aa070d..9b872c991af8 100644
--- a/dev-ruby/activeresource/ChangeLog
+++ b/dev-ruby/activeresource/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/activeresource
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.89 2011/08/07 18:06:36 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.90 2011/08/17 08:40:09 graaff Exp $
+
+*activeresource-2.3.14 (17 Aug 2011)
+
+ 17 Aug 2011; Hans de Graaff <graaff@gentoo.org>
+ +activeresource-2.3.14.ebuild:
+ Version bump.
07 Aug 2011; Raúl Porcel <armin76@gentoo.org> activeresource-3.0.9.ebuild:
Add ~ia64/~sparc wrt #351835
diff --git a/dev-ruby/activeresource/activeresource-2.3.14.ebuild b/dev-ruby/activeresource/activeresource-2.3.14.ebuild
new file mode 100644
index 000000000000..e9f2e1f9aa8b
--- /dev/null
+++ b/dev-ruby/activeresource/activeresource-2.3.14.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/activeresource-2.3.14.ebuild,v 1.1 2011/08/17 08:40:09 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18 jruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Think Active Record for web resources.."
+HOMEPAGE="http://rubyforge.org/projects/activeresource/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 -x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}"
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ )"
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}/${PN}-2.3.10-rails3.patch"
+
+ # Custom template not found in package
+ sed -i -e '/horo/d' Rakefile || die
+}