summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-03-12 17:27:27 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-03-12 17:27:27 +0000
commit1340df32172d893282406577f85bb775ac44fe62 (patch)
tree0799b7344e2eb48fa4b7ec50ce8cbe209a2e21ab /dev-ruby
parentRevert back to ~ppc64 because this is not ready to be stabilized. (diff)
downloadgentoo-2-1340df32172d893282406577f85bb775ac44fe62.tar.gz
gentoo-2-1340df32172d893282406577f85bb775ac44fe62.tar.bz2
gentoo-2-1340df32172d893282406577f85bb775ac44fe62.zip
Version bump (keep one open to stable, and one with ruby19).
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/tzinfo/ChangeLog9
-rw-r--r--dev-ruby/tzinfo/tzinfo-0.3.32-r1.ebuild40
-rw-r--r--dev-ruby/tzinfo/tzinfo-0.3.32.ebuild40
3 files changed, 88 insertions, 1 deletions
diff --git a/dev-ruby/tzinfo/ChangeLog b/dev-ruby/tzinfo/ChangeLog
index 391c5207a3ff..c7f89a6f4c7d 100644
--- a/dev-ruby/tzinfo/ChangeLog
+++ b/dev-ruby/tzinfo/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/tzinfo
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/ChangeLog,v 1.100 2012/03/09 06:52:03 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/ChangeLog,v 1.101 2012/03/12 17:27:27 flameeyes Exp $
+
+*tzinfo-0.3.32 (12 Mar 2012)
+*tzinfo-0.3.32-r1 (12 Mar 2012)
+
+ 12 Mar 2012; Diego E. Pettenò <flameeyes@gentoo.org> +tzinfo-0.3.32-r1.ebuild,
+ +tzinfo-0.3.32.ebuild:
+ Version bump (keep one open to stable, and one with ruby19).
09 Mar 2012; Hans de Graaff <graaff@gentoo.org> -tzinfo-0.3.27.ebuild:
Remove old version.
diff --git a/dev-ruby/tzinfo/tzinfo-0.3.32-r1.ebuild b/dev-ruby/tzinfo/tzinfo-0.3.32-r1.ebuild
new file mode 100644
index 000000000000..1472a2394cdb
--- /dev/null
+++ b/dev-ruby/tzinfo/tzinfo-0.3.32-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/tzinfo-0.3.32-r1.ebuild,v 1.1 2012/03/12 17:27:27 flameeyes Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+# No longer compatible with rake 0.9 starting with 0.3.31.
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Daylight-savings aware timezone library"
+HOMEPAGE="http://tzinfo.rubyforge.org/"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
+
+all_ruby_prepare() {
+ # With rubygems 1.3.1 we get the following warning
+ # warning: Insecure world writable dir /var/tmp in LOAD_PATH, mode 041777
+ # when running the test_get_tainted_not_loaded test.
+ sed -i \
+ -e '/^ def test_get_tainted_not_loaded/, /^ end/ s:^:#:' \
+ "${S}"/test/tc_timezone.rb || die "unable to sed out the test"
+}
+
+each_ruby_test() {
+ TZ='America/Los_Angeles' ${RUBY} -I. -S testrb test/tc_*.rb || die
+}
diff --git a/dev-ruby/tzinfo/tzinfo-0.3.32.ebuild b/dev-ruby/tzinfo/tzinfo-0.3.32.ebuild
new file mode 100644
index 000000000000..5e5388755233
--- /dev/null
+++ b/dev-ruby/tzinfo/tzinfo-0.3.32.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/tzinfo-0.3.32.ebuild,v 1.1 2012/03/12 17:27:27 flameeyes Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 jruby"
+
+# No longer compatible with rake 0.9 starting with 0.3.31.
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Daylight-savings aware timezone library"
+HOMEPAGE="http://tzinfo.rubyforge.org/"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
+
+all_ruby_prepare() {
+ # With rubygems 1.3.1 we get the following warning
+ # warning: Insecure world writable dir /var/tmp in LOAD_PATH, mode 041777
+ # when running the test_get_tainted_not_loaded test.
+ sed -i \
+ -e '/^ def test_get_tainted_not_loaded/, /^ end/ s:^:#:' \
+ "${S}"/test/tc_timezone.rb || die "unable to sed out the test"
+}
+
+each_ruby_test() {
+ TZ='America/Los_Angeles' ${RUBY} -I. -S testrb test/tc_*.rb || die
+}