summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-10-06 09:51:43 +0000
committerHans de Graaff <graaff@gentoo.org>2013-10-06 09:51:43 +0000
commit254fa3ff6f40d7676e5b5c9c35ab8876212ce9be (patch)
treefb0b0058890a86eaba0c9acd1a06ec20a7cec284 /dev-ruby
parentVersion bump. Add ruby20. Skip tests failing due to newer libxml2. (diff)
downloadgentoo-2-254fa3ff6f40d7676e5b5c9c35ab8876212ce9be.tar.gz
gentoo-2-254fa3ff6f40d7676e5b5c9c35ab8876212ce9be.tar.bz2
gentoo-2-254fa3ff6f40d7676e5b5c9c35ab8876212ce9be.zip
Add ruby20.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rspec-core/ChangeLog5
-rw-r--r--dev-ruby/rspec-core/rspec-core-2.14.3.ebuild9
2 files changed, 10 insertions, 4 deletions
diff --git a/dev-ruby/rspec-core/ChangeLog b/dev-ruby/rspec-core/ChangeLog
index 9c4a9bbb1f24..f9455e48c1b1 100644
--- a/dev-ruby/rspec-core/ChangeLog
+++ b/dev-ruby/rspec-core/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/rspec-core
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/ChangeLog,v 1.57 2013/07/21 07:13:50 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/ChangeLog,v 1.58 2013/10/06 09:51:43 graaff Exp $
+
+ 06 Oct 2013; Hans de Graaff <graaff@gentoo.org> rspec-core-2.14.3.ebuild:
+ Add ruby20.
21 Jul 2013; Hans de Graaff <graaff@gentoo.org> -rspec-core-2.13.0.ebuild:
Cleanup.
diff --git a/dev-ruby/rspec-core/rspec-core-2.14.3.ebuild b/dev-ruby/rspec-core/rspec-core-2.14.3.ebuild
index e61ea14ca8cd..b63deaf44006 100644
--- a/dev-ruby/rspec-core/rspec-core-2.14.3.ebuild
+++ b/dev-ruby/rspec-core/rspec-core-2.14.3.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/rspec-core-2.14.3.ebuild,v 1.1 2013/07/20 06:45:56 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/rspec-core-2.14.3.ebuild,v 1.2 2013/10/06 09:51:43 graaff Exp $
EAPI=5
-USE_RUBY="ruby18 ruby19 jruby"
+USE_RUBY="ruby18 ruby19 ruby20 jruby"
RUBY_FAKEGEM_TASK_TEST="none"
RUBY_FAKEGEM_TASK_DOC="none"
@@ -33,7 +33,10 @@ ruby_add_bdepend "test? (
>=dev-ruby/rspec-expectations-2.14.0:2
>=dev-ruby/rspec-mocks-2.12.0:2
)"
-ruby_add_bdepend "doc? ( dev-ruby/yard )"
+
+# Skip yard for ruby20 for now since we don't support ruby20 eselected
+# yet and we can't bootstrap otherwise.
+USE_RUBY=${USE_RUBY/ruby20/} ruby_add_bdepend "doc? ( dev-ruby/yard )"
all_ruby_prepare() {
# Don't set up bundler: it doesn't understand our setup.