summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-07-04 09:34:03 +0000
committerHans de Graaff <graaff@gentoo.org>2011-07-04 09:34:03 +0000
commit383851e8836cca5ed96d2d490b315b20b3c757f0 (patch)
tree12001faff1bf2e554f8d3fc4edeacb542cc70fbb /dev-ruby
parentVersion bump for Rails 3.0.9. (diff)
downloadgentoo-2-383851e8836cca5ed96d2d490b315b20b3c757f0.tar.gz
gentoo-2-383851e8836cca5ed96d2d490b315b20b3c757f0.tar.bz2
gentoo-2-383851e8836cca5ed96d2d490b315b20b3c757f0.zip
Version bump for Rails 3.0.9.
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/actionpack/ChangeLog7
-rw-r--r--dev-ruby/actionpack/actionpack-3.0.9.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/dev-ruby/actionpack/ChangeLog b/dev-ruby/actionpack/ChangeLog
index 36b2d951ea4d..2c345f8245a8 100644
--- a/dev-ruby/actionpack/ChangeLog
+++ b/dev-ruby/actionpack/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionpack
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.178 2011/06/19 09:48:46 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.179 2011/07/04 09:34:03 graaff Exp $
+
+*actionpack-3.0.9 (04 Jul 2011)
+
+ 04 Jul 2011; Hans de Graaff <graaff@gentoo.org> +actionpack-3.0.9.ebuild:
+ Version bump for Rails 3.0.9.
19 Jun 2011; Alex Legler <a3li@gentoo.org> actionpack-2.3.5.ebuild:
Restrict rack dependency to 1.0*
diff --git a/dev-ruby/actionpack/actionpack-3.0.9.ebuild b/dev-ruby/actionpack/actionpack-3.0.9.ebuild
new file mode 100644
index 000000000000..77ad4f872ab7
--- /dev/null
+++ b/dev-ruby/actionpack/actionpack-3.0.9.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/actionpack-3.0.9.ebuild,v 1.1 2011/07/04 09:34:03 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18"
+
+# The default test task tries to test activerecord with SQLite as well.
+RUBY_FAKEGEM_TASK_TEST="test_action_pack"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Eases web-request routing, handling, and response."
+HOMEPAGE="http://rubyforge.org/projects/actionpack/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+S="${WORKDIR}/rails-rails-*/actionpack"
+
+ruby_add_rdepend "
+ ~dev-ruby/activemodel-${PV}
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-2.1.2:0
+ >=dev-ruby/erubis-2.6.6
+ >=dev-ruby/i18n-0.5.0:0.5
+ >=dev-ruby/rack-1.2.1:1.2
+ >=dev-ruby/rack-mount-0.6.14:0.6
+ >=dev-ruby/rack-test-0.5.7
+ >=dev-ruby/tzinfo-0.3.23"
+
+ruby_add_bdepend "
+ test? (
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/actionmailer-${PV}
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/\/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ # Loosen erubis dependency since this is not slotted.
+ sed -i -e 's/~> 2.6.6/>= 2.6.6/' actionpack.gemspec || die
+}