summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-01-14 08:11:59 +0000
committerHans de Graaff <graaff@gentoo.org>2012-01-14 08:11:59 +0000
commit3b2fd560a6cc0fa26ef650b091a42f9d8b7d1ad1 (patch)
tree533c6e1f2431546348d6cc003884c82e4f2c6a2c /dev-ruby
parentDrop has_m32 as this is the only package to use it, and we do not really *nee... (diff)
downloadgentoo-2-3b2fd560a6cc0fa26ef650b091a42f9d8b7d1ad1.tar.gz
gentoo-2-3b2fd560a6cc0fa26ef650b091a42f9d8b7d1ad1.tar.bz2
gentoo-2-3b2fd560a6cc0fa26ef650b091a42f9d8b7d1ad1.zip
Version bump.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/coderay/ChangeLog9
-rw-r--r--dev-ruby/coderay/coderay-1.0.5.ebuild35
2 files changed, 42 insertions, 2 deletions
diff --git a/dev-ruby/coderay/ChangeLog b/dev-ruby/coderay/ChangeLog
index 9a99f2dd1100..636560731599 100644
--- a/dev-ruby/coderay/ChangeLog
+++ b/dev-ruby/coderay/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/coderay
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/coderay/ChangeLog,v 1.47 2011/12/31 20:34:42 grobian Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/coderay/ChangeLog,v 1.48 2012/01/14 08:11:59 graaff Exp $
+
+*coderay-1.0.5 (14 Jan 2012)
+
+ 14 Jan 2012; Hans de Graaff <graaff@gentoo.org> +coderay-1.0.5.ebuild:
+ Version bump.
31 Dec 2011; Fabian Groffen <grobian@gentoo.org> coderay-1.0.4.ebuild:
Add Prefix keywords, bug #396547
diff --git a/dev-ruby/coderay/coderay-1.0.5.ebuild b/dev-ruby/coderay/coderay-1.0.5.ebuild
new file mode 100644
index 000000000000..07fc93037f32
--- /dev/null
+++ b/dev-ruby/coderay/coderay-1.0.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/coderay/coderay-1.0.5.ebuild,v 1.1 2012/01/14 08:11:59 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ree18 ruby19"
+
+# The test target also contains test:exe but that requires
+# shoulda-context which we do not have packaged yet.
+RUBY_FAKEGEM_TASK_TEST="test:functional test:units"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="Changes-pre-1.0.textile Changes.textile FOLDERS README_INDEX.rdoc README.textile"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby library for syntax highlighting."
+HOMEPAGE="http://coderay.rubychan.de/"
+SRC_URI="https://github.com/rubychan/coderay/tarball/v${PV} -> ${P}.tgz"
+
+RUBY_S="rubychan-coderay-*"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# Redcloth is optional but automagically tested, so we add this
+# dependency to ensure that we get at least a version that works: bug
+# 330621. We use this convoluted way because redcloth isn't available
+# yet for jruby.
+USE_RUBY="${USE_RUBY/jruby/}" ruby_add_bdepend "test? ( >=dev-ruby/redcloth-4.2.2 )"