summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-02-23 16:17:06 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-02-23 16:17:06 +0000
commit4044a3231fa6c80dc88fe32ec55f54b6ef02a0a7 (patch)
tree24175d11d38e3fb6370ebc667fbb7e7946c1b365 /dev-ruby
parentVersion bump. (diff)
downloadgentoo-2-4044a3231fa6c80dc88fe32ec55f54b6ef02a0a7.tar.gz
gentoo-2-4044a3231fa6c80dc88fe32ec55f54b6ef02a0a7.tar.bz2
gentoo-2-4044a3231fa6c80dc88fe32ec55f54b6ef02a0a7.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/map/ChangeLog7
-rw-r--r--dev-ruby/map/map-6.5.3.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-ruby/map/ChangeLog b/dev-ruby/map/ChangeLog
index 476d4af9db68..8669a0d9164b 100644
--- a/dev-ruby/map/ChangeLog
+++ b/dev-ruby/map/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/map
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/map/ChangeLog,v 1.12 2014/02/14 10:31:28 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/map/ChangeLog,v 1.13 2014/02/23 16:17:06 mrueg Exp $
+
+*map-6.5.3 (23 Feb 2014)
+
+ 23 Feb 2014; Manuel Rüger <mrueg@gentoo.org> +map-6.5.3.ebuild:
+ Version bump.
*map-6.5.2 (14 Feb 2014)
diff --git a/dev-ruby/map/map-6.5.3.ebuild b/dev-ruby/map/map-6.5.3.ebuild
new file mode 100644
index 000000000000..1c348413c915
--- /dev/null
+++ b/dev-ruby/map/map-6.5.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/map/map-6.5.3.ebuild,v 1.1 2014/02/23 16:17:06 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ruby20 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README"
+
+RUBY_FAKEGEM_GEMSPEC="map.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A string/symbol indifferent ordered hash that works in all rubies."
+HOMEPAGE="http://github.com/ahoward/map"
+
+LICENSE="|| ( Ruby BSD-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *ruby18)
+ epatch "${FILESDIR}/ruby18-failing-tests.patch"
+ epatch "${FILESDIR}/${PN}-6.5.1-ruby18-failing-tests.patch"
+ ;;
+ *jruby)
+ epatch "${FILESDIR}/${PN}-6.5.1-ruby18-failing-tests.patch"
+ ;;
+ *)
+ ;;
+ esac
+}