summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-04-24 20:57:13 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-04-24 20:57:13 +0000
commit43686c82b3c02967e4f8a0b25678375614c260cc (patch)
tree651e95f38374b9ca78ac4d5e5355248fa470c8b6 /dev-ruby
parentReplace dependency on virtual/modutils, bug 358891. Whitespace. (diff)
downloadgentoo-2-43686c82b3c02967e4f8a0b25678375614c260cc.tar.gz
gentoo-2-43686c82b3c02967e4f8a0b25678375614c260cc.tar.bz2
gentoo-2-43686c82b3c02967e4f8a0b25678375614c260cc.zip
Initial import of the posix-spawn gem.
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/posix-spawn/ChangeLog10
-rw-r--r--dev-ruby/posix-spawn/metadata.xml5
-rw-r--r--dev-ruby/posix-spawn/posix-spawn-0.3.6.ebuild29
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-ruby/posix-spawn/ChangeLog b/dev-ruby/posix-spawn/ChangeLog
new file mode 100644
index 000000000000..98b279dddc3a
--- /dev/null
+++ b/dev-ruby/posix-spawn/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ruby/posix-spawn
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/posix-spawn/ChangeLog,v 1.1 2011/04/24 20:57:13 flameeyes Exp $
+
+*posix-spawn-0.3.6 (24 Apr 2011)
+
+ 24 Apr 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+ +posix-spawn-0.3.6.ebuild, +metadata.xml:
+ Initial import of the posix-spawn gem.
+
diff --git a/dev-ruby/posix-spawn/metadata.xml b/dev-ruby/posix-spawn/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/posix-spawn/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/posix-spawn/posix-spawn-0.3.6.ebuild b/dev-ruby/posix-spawn/posix-spawn-0.3.6.ebuild
new file mode 100644
index 000000000000..a522208c74cf
--- /dev/null
+++ b/dev-ruby/posix-spawn/posix-spawn-0.3.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/posix-spawn/posix-spawn-0.3.6.ebuild,v 1.1 2011/04/24 20:57:13 flameeyes Exp $
+
+EAPI=2
+
+# jruby → should be supported but does not work with "rake compile"
+USE_RUBY="ruby18 ruby19 ree18"
+KEYWORDS="~amd64"
+
+RUBY_FAKEGEM_EXTRADOC="README.md TODO HACKING"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby library to access ELF files information"
+HOMEPAGE="http://www.flameeyes.eu/projects/ruby-elf"
+
+LICENSE="MIT LGPL-2.1"
+SLOT="0"
+IUSE="test"
+
+ruby_add_bdepend ">=dev-ruby/rake-compiler-0.7.6"
+
+# https://github.com/rtomayko/posix-spawn/issues/11
+RESTRICT=test
+
+each_ruby_compile() {
+ ${RUBY} -S rake compile || die
+}