summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-09-29 12:14:36 +0000
committerHans de Graaff <graaff@gentoo.org>2011-09-29 12:14:36 +0000
commit6472996ced16a835915400275b9dadf33c33b0dd (patch)
tree63b0b07a99fa502f0faabc4b0282e11b35018d70 /dev-ruby
parentAdd ~x86 keyword. (diff)
downloadgentoo-2-6472996ced16a835915400275b9dadf33c33b0dd.tar.gz
gentoo-2-6472996ced16a835915400275b9dadf33c33b0dd.tar.bz2
gentoo-2-6472996ced16a835915400275b9dadf33c33b0dd.zip
Version bump.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/oauth2/ChangeLog7
-rw-r--r--dev-ruby/oauth2/oauth2-0.5.1.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-ruby/oauth2/ChangeLog b/dev-ruby/oauth2/ChangeLog
index c76e172532f4..148a668b496a 100644
--- a/dev-ruby/oauth2/ChangeLog
+++ b/dev-ruby/oauth2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/oauth2
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/ChangeLog,v 1.10 2011/07/24 20:09:43 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/ChangeLog,v 1.11 2011/09/29 12:14:36 graaff Exp $
+
+*oauth2-0.5.1 (29 Sep 2011)
+
+ 29 Sep 2011; Hans de Graaff <graaff@gentoo.org> +oauth2-0.5.1.ebuild:
+ Version bump.
24 Jul 2011; Thomas Kahle <tomka@gentoo.org> oauth2-0.4.1.ebuild:
~x86 per bug 375153
diff --git a/dev-ruby/oauth2/oauth2-0.5.1.ebuild b/dev-ruby/oauth2/oauth2-0.5.1.ebuild
new file mode 100644
index 000000000000..ddb5a40fce40
--- /dev/null
+++ b/dev-ruby/oauth2/oauth2-0.5.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/oauth2-0.5.1.ebuild,v 1.1 2011/09/29 12:14:36 graaff Exp $
+
+EAPI="2"
+
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+RUBY_FAKEGEM_TASK_DOC="doc:rdoc"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Ruby wrapper for the OAuth 2.0 protocol built with a similar style to the original OAuth gem."
+HOMEPAGE="http://github.com/intridea/oauth2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/faraday-0.7.4 >=dev-ruby/multi_json-1.0.3"
+ruby_add_bdepend "test? ( >=dev-ruby/rspec-2.5.0:2 dev-ruby/multi_xml )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e "/[Bb]undler/d" -e "/[Ss]imple[Cc]ov/d" spec/helper.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -S rspec spec || die
+}