summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-11-23 19:25:52 +0000
committerHans de Graaff <graaff@gentoo.org>2011-11-23 19:25:52 +0000
commit66ecc9e639bee39a88f4f88cb046c1f777409936 (patch)
treef1507a07fd4a503322319b4ed572d84e69e2713c /dev-ruby
parentVersion bump, remove old. (diff)
downloadgentoo-2-66ecc9e639bee39a88f4f88cb046c1f777409936.tar.gz
gentoo-2-66ecc9e639bee39a88f4f88cb046c1f777409936.tar.bz2
gentoo-2-66ecc9e639bee39a88f4f88cb046c1f777409936.zip
Version bump. multibyte.txt is now included in the gem by upstream.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/multipart-post/ChangeLog7
-rw-r--r--dev-ruby/multipart-post/multipart-post-1.1.4.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-ruby/multipart-post/ChangeLog b/dev-ruby/multipart-post/ChangeLog
index ebfaa1a27c86..bfcc0d276289 100644
--- a/dev-ruby/multipart-post/ChangeLog
+++ b/dev-ruby/multipart-post/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/multipart-post
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multipart-post/ChangeLog,v 1.7 2011/11/20 08:21:44 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multipart-post/ChangeLog,v 1.8 2011/11/23 19:25:52 graaff Exp $
+
+*multipart-post-1.1.4 (23 Nov 2011)
+
+ 23 Nov 2011; Hans de Graaff <graaff@gentoo.org> +multipart-post-1.1.4.ebuild:
+ Version bump. multibyte.txt is now included in the gem by upstream.
20 Nov 2011; Hans de Graaff <graaff@gentoo.org> multipart-post-1.1.3.ebuild,
+files/multibyte.txt:
diff --git a/dev-ruby/multipart-post/multipart-post-1.1.4.ebuild b/dev-ruby/multipart-post/multipart-post-1.1.4.ebuild
new file mode 100644
index 000000000000..327bb122bd9d
--- /dev/null
+++ b/dev-ruby/multipart-post/multipart-post-1.1.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multipart-post/multipart-post-1.1.4.ebuild,v 1.1 2011/11/23 19:25:52 graaff Exp $
+
+EAPI="2"
+
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.txt"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Adds a streamy multipart form post capability to Net::HTTP."
+HOMEPAGE="http://github.com/nicksieger/multipart-post"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
+
+each_ruby_test() {
+ ${RUBY} -S testrb -Ilib test || die "Tests failed."
+}