summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-02-02 14:12:45 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-02-02 14:12:45 +0000
commit674085e2cb8b880297cd3df60df6fa6f279c3c30 (patch)
tree9dbca76a4e55e1a8af7743a05f5f1402d9a46b11 /dev-ruby
parentAdd missing racc dependency; skip tests for JRuby since they require librarie... (diff)
downloadgentoo-2-674085e2cb8b880297cd3df60df6fa6f279c3c30.tar.gz
gentoo-2-674085e2cb8b880297cd3df60df6fa6f279c3c30.tar.bz2
gentoo-2-674085e2cb8b880297cd3df60df6fa6f279c3c30.zip
Use upstream specs fixes (as the custom one didn't work with Ruby 1.9) and add ruby19 support.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rspec-core/ChangeLog7
-rw-r--r--dev-ruby/rspec-core/files/rspec-core-2.4.0-tests.patch49
-rw-r--r--dev-ruby/rspec-core/rspec-core-2.4.0.ebuild5
3 files changed, 57 insertions, 4 deletions
diff --git a/dev-ruby/rspec-core/ChangeLog b/dev-ruby/rspec-core/ChangeLog
index 55f60b4928d8..f0d6121f49b2 100644
--- a/dev-ruby/rspec-core/ChangeLog
+++ b/dev-ruby/rspec-core/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rspec-core
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/ChangeLog,v 1.5 2011/01/15 17:02:39 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/ChangeLog,v 1.6 2011/02/02 14:12:44 flameeyes Exp $
+
+ 02 Feb 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+ rspec-core-2.4.0.ebuild, +files/rspec-core-2.4.0-tests.patch:
+ Use upstream specs fixes (as the custom one didn't work with Ruby 1.9) and
+ add ruby19 support.
*rspec-core-2.4.0 (15 Jan 2011)
diff --git a/dev-ruby/rspec-core/files/rspec-core-2.4.0-tests.patch b/dev-ruby/rspec-core/files/rspec-core-2.4.0-tests.patch
new file mode 100644
index 000000000000..157f1f054889
--- /dev/null
+++ b/dev-ruby/rspec-core/files/rspec-core-2.4.0-tests.patch
@@ -0,0 +1,49 @@
+From 22bd1e10147d43c4055cbb1b1f95872b84d88fdf Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Diego=20Elio=20Petten=C3=B2?= <flameeyes@gmail.com>
+Date: Wed, 2 Feb 2011 14:53:16 +0100
+Subject: [PATCH] Squashed commit of the following:
+
+commit 23727ceecc0ac619acb31bf5a0c850eb60a443b7
+Author: David Chelimsky <dchelimsky@gmail.com>
+Date: Sun Jan 16 16:42:48 2011 -0600
+
+ sort rather than match on unsorted content
+
+commit cdb8e160f1659dd148f56e12b5acc174444dda3c
+Author: David Chelimsky <dchelimsky@gmail.com>
+Date: Sun Jan 16 10:34:01 2011 -0600
+
+ loosen constraint on outcome in example that returns an array
+
+ - Closes #278.
+---
+ spec/rspec/core/rake_task_spec.rb | 6 +++---
+ 1 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/spec/rspec/core/rake_task_spec.rb b/spec/rspec/core/rake_task_spec.rb
+index 6ba16af..1bdf50a 100644
+--- a/spec/rspec/core/rake_task_spec.rb
++++ b/spec/rspec/core/rake_task_spec.rb
+@@ -144,16 +144,16 @@ module RSpec::Core
+ @task = RakeTask.new do |t|
+ t.pattern = File.join(@tmp_dir, "*spec.rb")
+ end
+- ["first_spec.rb", "second_\"spec.rb", "third_'spec.rb"].each do |file_name|
++ ["first_spec.rb", "second_\"spec.rb", "third_\'spec.rb"].each do |file_name|
+ FileUtils.touch(File.join(@tmp_dir, file_name))
+ end
+ end
+
+ it "escapes the quotes" do
+- @task.__send__(:files_to_run).should eq([
++ @task.__send__(:files_to_run).sort.should eq([
+ File.join(@tmp_dir, "first_spec.rb"),
+ File.join(@tmp_dir, "second_\\\"spec.rb"),
+- File.join(@tmp_dir, "third_\\'spec.rb")
++ File.join(@tmp_dir, "third_\\\'spec.rb")
+ ])
+ end
+ end
+--
+1.7.4
+
diff --git a/dev-ruby/rspec-core/rspec-core-2.4.0.ebuild b/dev-ruby/rspec-core/rspec-core-2.4.0.ebuild
index 5fac6c91cbe3..b0d0544aa93e 100644
--- a/dev-ruby/rspec-core/rspec-core-2.4.0.ebuild
+++ b/dev-ruby/rspec-core/rspec-core-2.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/rspec-core-2.4.0.ebuild,v 1.1 2011/01/15 17:02:39 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/rspec-core-2.4.0.ebuild,v 1.2 2011/02/02 14:12:44 flameeyes Exp $
EAPI=2
USE_RUBY="ruby18 ree18 ruby19"
@@ -42,8 +42,7 @@ all_ruby_prepare() {
# Also clean the /usr/lib/rubyee path (which is our own invention).
sed -i -e 's#lib\\d\*\\/ruby\\/#lib\\d*\\/ruby(ee|)\\/#' lib/rspec/core/configuration.rb || die
- # Fix spec: https://github.com/rspec/rspec-core/issues/issue/278
- sed -i -e '157c].reverse)' spec/rspec/core/rake_task_spec.rb || die
+ epatch "${FILESDIR}"/${P}-tests.patch
}
all_ruby_compile() {