summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-06-16 06:19:02 +0000
committerHans de Graaff <graaff@gentoo.org>2011-06-16 06:19:02 +0000
commit6b0cca586a9acf2b9b30d7c9f5d26d6b0addc751 (patch)
tree3d40c7d78af9c4d189f3479ecd3bfb01a27997fa /dev-ruby
parentversion bump (diff)
downloadgentoo-2-6b0cca586a9acf2b9b30d7c9f5d26d6b0addc751.tar.gz
gentoo-2-6b0cca586a9acf2b9b30d7c9f5d26d6b0addc751.tar.bz2
gentoo-2-6b0cca586a9acf2b9b30d7c9f5d26d6b0addc751.zip
Version bump.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/yard/ChangeLog7
-rw-r--r--dev-ruby/yard/yard-0.7.2.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-ruby/yard/ChangeLog b/dev-ruby/yard/ChangeLog
index a142bf45347d..885776fb9dae 100644
--- a/dev-ruby/yard/ChangeLog
+++ b/dev-ruby/yard/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/yard
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/yard/ChangeLog,v 1.17 2011/06/05 08:09:20 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/yard/ChangeLog,v 1.18 2011/06/16 06:19:02 graaff Exp $
+
+*yard-0.7.2 (16 Jun 2011)
+
+ 16 Jun 2011; Hans de Graaff <graaff@gentoo.org> +yard-0.7.2.ebuild:
+ Version bump.
*yard-0.7.1 (05 Jun 2011)
diff --git a/dev-ruby/yard/yard-0.7.2.ebuild b/dev-ruby/yard/yard-0.7.2.ebuild
new file mode 100644
index 000000000000..446704055ddc
--- /dev/null
+++ b/dev-ruby/yard/yard-0.7.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/yard/yard-0.7.2.ebuild,v 1.1 2011/06/16 06:19:02 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="specs"
+RUBY_FAKEGEM_TASK_DOC="yard"
+
+RUBY_FAKEGEM_EXTRADOC="README.md ChangeLog"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="templates"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Documentation generation tool for the Ruby programming language"
+HOMEPAGE="http://yardoc.org/"
+
+LICENSE="as-is" # truly
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "doc? ( || ( dev-ruby/bluecloth dev-ruby/maruku dev-ruby/rdiscount dev-ruby/kramdown ) )"
+ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *jruby)
+ # Work around what appears to be a rubygems incompatibility where
+ # requireing rubygems triggers expectations set by rspec. Not
+ # reported upstream yet.
+ rm spec/cli/diff_spec.rb || die
+
+ # This spec requires rdiscount which is a C extension.
+ sed -i -e '131s/should/should_not/' spec/templates/helpers/html_helper_spec.rb || die
+ ;;
+ *)
+ ;;
+ esac
+}