summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-02-19 07:19:19 +0000
committerHans de Graaff <graaff@gentoo.org>2014-02-19 07:19:19 +0000
commit8de5b8111f1c6145942731a48b80fcdf9a891462 (patch)
treebad5d7b99f2b248fdc907488662515f74e8821a5 /dev-ruby
parentVersion bump for security bug 501750. (diff)
downloadgentoo-2-8de5b8111f1c6145942731a48b80fcdf9a891462.tar.gz
gentoo-2-8de5b8111f1c6145942731a48b80fcdf9a891462.tar.bz2
gentoo-2-8de5b8111f1c6145942731a48b80fcdf9a891462.zip
Version bump for security bug 501750.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/actionpack/ChangeLog7
-rw-r--r--dev-ruby/actionpack/actionpack-3.2.17.ebuild74
2 files changed, 80 insertions, 1 deletions
diff --git a/dev-ruby/actionpack/ChangeLog b/dev-ruby/actionpack/ChangeLog
index 1b17c5caeda8..90f01b6fe2a3 100644
--- a/dev-ruby/actionpack/ChangeLog
+++ b/dev-ruby/actionpack/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionpack
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.266 2014/01/18 09:54:00 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.267 2014/02/19 07:19:18 graaff Exp $
+
+*actionpack-3.2.17 (19 Feb 2014)
+
+ 19 Feb 2014; Hans de Graaff <graaff@gentoo.org> +actionpack-3.2.17.ebuild:
+ Version bump for security bug 501750.
18 Jan 2014; Hans de Graaff <graaff@gentoo.org> -actionpack-2.3.18.ebuild:
Remove masked version.
diff --git a/dev-ruby/actionpack/actionpack-3.2.17.ebuild b/dev-ruby/actionpack/actionpack-3.2.17.ebuild
new file mode 100644
index 000000000000..fffb1be15a61
--- /dev/null
+++ b/dev-ruby/actionpack/actionpack-3.2.17.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/actionpack-3.2.17.ebuild,v 1.1 2014/02/19 07:19:19 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19"
+
+# The default test task tries to test activerecord with SQLite as well.
+RUBY_FAKEGEM_TASK_TEST="test_action_pack"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Eases web-request routing, handling, and response."
+HOMEPAGE="http://rubyforge.org/projects/actionpack/"
+SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activemodel-${PV}
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/rack-cache-1.2
+ >=dev-ruby/builder-3.0.0:3
+ >=dev-ruby/rack-1.4.5:1.4
+ >=dev-ruby/rack-test-0.6.1:0.6
+ >=dev-ruby/journey-1.0.4:1.0
+ >=dev-ruby/sprockets-2.2.1:2.2
+ >=dev-ruby/erubis-2.7.0"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/mocha:0.13
+ dev-ruby/bundler
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/actionmailer-${PV}
+ >=dev-ruby/tzinfo-0.3.29:0
+ >=dev-ruby/uglifier-1.0.3
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|benchmark-ips\)/d" ../Gemfile || die
+
+ sed -i -e '/rack-ssl/d' -e 's/~> 3.4/>= 3.4/' ../railties/railties.gemspec || die
+ sed -i -e '/mail/d' ../actionmailer/actionmailer.gemspec || die
+
+ sed -i -e '/bcrypt/ s/3.0.0/3.0/' ../Gemfile || die
+
+ # Avoid fragile tests depending on hash ordering
+ sed -i -e '/cookie_3=chocolate/ s:^:#:' test/controller/integration_test.rb || die
+ sed -i -e '/test_to_s/,/end/ s:^:#:' test/template/html-scanner/tag_node_test.rb || die
+ sed -i -e '/"name":"david"/ s:^:#:' test/controller/mime_responds_test.rb || die
+ sed -i -e '/test_option_html_attributes_with_multiple_element_hash/, / end/ s:^:#:' test/template/form_options_helper_test.rb || die
+ sed -i -e '/test_option_html_attributes_with_multiple_hashes/, / end/ s:^:#:' test/template/form_options_helper_test.rb || die
+
+ # Avoid fragile test that gets more output than it expects.
+ sed -i -e '/test_locals_option_to_assert_template_is_not_supported/,/end/ s:^:#:' test/controller/render_test.rb || die
+
+ # Avoid test broken by security updates in i18n.
+ sed -i -e '/test_number_to_i18n_currency/,/end/ s:^:#:' test/template/number_helper_i18n_test.rb || die
+}