summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-12-18 17:53:34 +0000
committerHans de Graaff <graaff@gentoo.org>2011-12-18 17:53:34 +0000
commit92ccdae300a973a6a700134c07d31016fc03cdf2 (patch)
tree90731018c80ba2bba9f3d746b3d30a90b9c56318 /dev-ruby
parentDrop sparc keywords (diff)
downloadgentoo-2-92ccdae300a973a6a700134c07d31016fc03cdf2.tar.gz
gentoo-2-92ccdae300a973a6a700134c07d31016fc03cdf2.tar.bz2
gentoo-2-92ccdae300a973a6a700134c07d31016fc03cdf2.zip
Version bump.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/method_source/ChangeLog7
-rw-r--r--dev-ruby/method_source/method_source-0.6.7.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-ruby/method_source/ChangeLog b/dev-ruby/method_source/ChangeLog
index 479f28321112..a818dab9c966 100644
--- a/dev-ruby/method_source/ChangeLog
+++ b/dev-ruby/method_source/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/method_source
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/method_source/ChangeLog,v 1.2 2011/10/16 08:44:34 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/method_source/ChangeLog,v 1.3 2011/12/18 17:53:34 graaff Exp $
+
+*method_source-0.6.7 (18 Dec 2011)
+
+ 18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +method_source-0.6.7.ebuild:
+ Version bump.
*method_source-0.6.6 (16 Oct 2011)
diff --git a/dev-ruby/method_source/method_source-0.6.7.ebuild b/dev-ruby/method_source/method_source-0.6.7.ebuild
new file mode 100644
index 000000000000..4870fc82d0c8
--- /dev/null
+++ b/dev-ruby/method_source/method_source-0.6.7.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/method_source/method_source-0.6.7.ebuild,v 1.1 2011/12/18 17:53:34 graaff Exp $
+
+EAPI=4
+# jruby crashes on parsing the metadata.
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+RUBY_FAKEGEM_GEMSPEC="method_source.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Retrieve the source code for a method."
+HOMEPAGE="http://github.com/banister/method_source"
+IUSE=""
+SLOT="0"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+
+ruby_add_bdepend "test? ( >=dev-ruby/bacon-1.1.0 )"
+
+ruby_add_rdepend ">=dev-ruby/ruby_parser-2.3.1"
+
+each_ruby_test() {
+ ${RUBY} -I. -S bacon -k test/test.rb || die "Tests failed."
+}