summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-06-13 17:40:36 +0000
committerHans de Graaff <graaff@gentoo.org>2012-06-13 17:40:36 +0000
commit93abc7bc4077ee0a16718e666ffd3487a626e880 (patch)
treed1ff0136fedf24b25074954badb93f2447fa8e0c /dev-ruby
parentAdd ~ppc based on comment 2 in bug 398985. (diff)
downloadgentoo-2-93abc7bc4077ee0a16718e666ffd3487a626e880.tar.gz
gentoo-2-93abc7bc4077ee0a16718e666ffd3487a626e880.tar.bz2
gentoo-2-93abc7bc4077ee0a16718e666ffd3487a626e880.zip
Version bump for Rails 3.0.15.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/activesupport/ChangeLog7
-rw-r--r--dev-ruby/activesupport/activesupport-3.0.15.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-ruby/activesupport/ChangeLog b/dev-ruby/activesupport/ChangeLog
index 75a321fb3266..0bd874d7d72f 100644
--- a/dev-ruby/activesupport/ChangeLog
+++ b/dev-ruby/activesupport/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activesupport
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.172 2012/06/13 06:23:16 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.173 2012/06/13 17:40:36 graaff Exp $
+
+*activesupport-3.0.15 (13 Jun 2012)
+
+ 13 Jun 2012; Hans de Graaff <graaff@gentoo.org> +activesupport-3.0.15.ebuild:
+ Version bump for Rails 3.0.15.
*activesupport-3.2.6 (13 Jun 2012)
diff --git a/dev-ruby/activesupport/activesupport-3.0.15.ebuild b/dev-ruby/activesupport/activesupport-3.0.15.ebuild
new file mode 100644
index 000000000000..a9cf1d05bc30
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-3.0.15.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-3.0.15.ebuild,v 1.1 2012/06/13 17:40:36 graaff Exp $
+
+EAPI=4
+
+# jruby fails tests.
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+SRC_URI="https://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/${PN}"
+
+ruby_add_rdepend ">=dev-ruby/memcache-client-1.5.8"
+
+# libxml-ruby and nokogiri are not strictly needed, but there are tests
+# using this code.
+ruby_add_bdepend "test? ( virtual/ruby-test-unit >=dev-ruby/libxml-2.0.0 dev-ruby/nokogiri =dev-ruby/mocha-0.10.5 )"
+
+all_ruby_prepare() {
+ # don't support older mocha versions as the optional codepath
+ # breaks JRuby
+ epatch "${FILESDIR}"/${PN}-3.0.3-mocha-0.9.5.patch
+
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+}