summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-02-21 15:17:24 +0000
committerHans de Graaff <graaff@gentoo.org>2014-02-21 15:17:24 +0000
commit993505e80d6e9b9e2fc019c4119743d305bdc015 (patch)
treea5256ae365a74909dd5345beef70bdb17b943bf3 /dev-ruby
parentdev-vcs/git-cola: Fix html doc installation, #472048; drop old (diff)
downloadgentoo-2-993505e80d6e9b9e2fc019c4119743d305bdc015.tar.gz
gentoo-2-993505e80d6e9b9e2fc019c4119743d305bdc015.tar.bz2
gentoo-2-993505e80d6e9b9e2fc019c4119743d305bdc015.zip
Initial import. New dependency for dev-ruby/twitter.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/http_parser_rb/ChangeLog10
-rw-r--r--dev-ruby/http_parser_rb/http_parser_rb-0.6.0.ebuild32
-rw-r--r--dev-ruby/http_parser_rb/metadata.xml5
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-ruby/http_parser_rb/ChangeLog b/dev-ruby/http_parser_rb/ChangeLog
new file mode 100644
index 000000000000..9b33fb2d5445
--- /dev/null
+++ b/dev-ruby/http_parser_rb/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ruby/http_parser_rb
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/http_parser_rb/ChangeLog,v 1.1 2014/02/21 15:17:24 graaff Exp $
+
+*http_parser_rb-0.6.0 (21 Feb 2014)
+
+ 21 Feb 2014; Hans de Graaff <graaff@gentoo.org> +http_parser_rb-0.6.0.ebuild,
+ +metadata.xml:
+ Initial import. New dependency for dev-ruby/twitter.
+
diff --git a/dev-ruby/http_parser_rb/http_parser_rb-0.6.0.ebuild b/dev-ruby/http_parser_rb/http_parser_rb-0.6.0.ebuild
new file mode 100644
index 000000000000..d7fff48d3e47
--- /dev/null
+++ b/dev-ruby/http_parser_rb/http_parser_rb-0.6.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/http_parser_rb/http_parser_rb-0.6.0.ebuild,v 1.1 2014/02/21 15:17:24 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_NAME="http_parser.rb"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple callback-based HTTP request/response parser"
+HOMEPAGE="http://github.com/tmm1/http_parser.rb"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+each_ruby_configure() {
+ ${RUBY} -Cext/ruby_http_parser extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/ruby_http_parser V=1
+ cp ext/ruby_http_parser/ruby_http_parser.so lib/ || die
+}
diff --git a/dev-ruby/http_parser_rb/metadata.xml b/dev-ruby/http_parser_rb/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/http_parser_rb/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>