summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-12-12 07:31:06 +0000
committerHans de Graaff <graaff@gentoo.org>2012-12-12 07:31:06 +0000
commita5f472fb0d359f716b804554677b785f1c8ee44d (patch)
tree55c8de19de73356a53b204c612170c800afb3d9c /dev-ruby
parentVersion bump. Removed old (diff)
downloadgentoo-2-a5f472fb0d359f716b804554677b785f1c8ee44d.tar.gz
gentoo-2-a5f472fb0d359f716b804554677b785f1c8ee44d.tar.bz2
gentoo-2-a5f472fb0d359f716b804554677b785f1c8ee44d.zip
Version bump.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/selenium-webdriver/ChangeLog8
-rw-r--r--dev-ruby/selenium-webdriver/selenium-webdriver-2.27.2.ebuild39
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-ruby/selenium-webdriver/ChangeLog b/dev-ruby/selenium-webdriver/ChangeLog
index e8af4dc36fb1..84f15deb87a8 100644
--- a/dev-ruby/selenium-webdriver/ChangeLog
+++ b/dev-ruby/selenium-webdriver/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/selenium-webdriver
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/selenium-webdriver/ChangeLog,v 1.36 2012/12/07 08:22:33 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/selenium-webdriver/ChangeLog,v 1.37 2012/12/12 07:31:06 graaff Exp $
+
+*selenium-webdriver-2.27.2 (12 Dec 2012)
+
+ 12 Dec 2012; Hans de Graaff <graaff@gentoo.org>
+ +selenium-webdriver-2.27.2.ebuild:
+ Version bump.
*selenium-webdriver-2.27.1 (07 Dec 2012)
diff --git a/dev-ruby/selenium-webdriver/selenium-webdriver-2.27.2.ebuild b/dev-ruby/selenium-webdriver/selenium-webdriver-2.27.2.ebuild
new file mode 100644
index 000000000000..f07c0bbe5a98
--- /dev/null
+++ b/dev-ruby/selenium-webdriver/selenium-webdriver-2.27.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/selenium-webdriver/selenium-webdriver-2.27.2.ebuild,v 1.1 2012/12/12 07:31:06 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19 ree18"
+
+# NOTE: this package contains precompiled code. It appears that all
+# source code can be found at http://code.google.com/p/selenium/ but the
+# repository is not organized in a way so that we can easily rebuild the
+# suited shared object. We'll just try our luck with the precompiled
+# objects for now.
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES README"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_QA_ALLOWED_LIBS="x_ignore_nofocus.so"
+
+inherit ruby-fakegem
+
+DESCRIPTION="This gem provides Ruby bindings for WebDriver."
+HOMEPAGE="http://gemcutter.org/gems/selenium-webdriver"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/childprocess-0.2.5
+ >=dev-ruby/multi_json-1.0.4
+ dev-ruby/rubyzip"
+
+all_ruby_prepare() {
+ # Make websocket a development dependency since it is only needed
+ # for the safari driver which we don't support on Gentoo.
+ sed -i -e '/libwebsocket/,/version_requirements/ s/runtime/development/' ../metadata || die
+}