summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-03-09 07:20:07 +0000
committerHans de Graaff <graaff@gentoo.org>2013-03-09 07:20:07 +0000
commita81730f0f8cda4b771c0098f185680c9a6cf146b (patch)
treebd12f09f4996e93db19cba72a20f38b596f9dc7a /dev-ruby
parentFix depends according to new LeechCraft category (diff)
downloadgentoo-2-a81730f0f8cda4b771c0098f185680c9a6cf146b.tar.gz
gentoo-2-a81730f0f8cda4b771c0098f185680c9a6cf146b.tar.bz2
gentoo-2-a81730f0f8cda4b771c0098f185680c9a6cf146b.zip
Version bump.
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/hashie/ChangeLog9
-rw-r--r--dev-ruby/hashie/hashie-2.0.2.ebuild28
2 files changed, 35 insertions, 2 deletions
diff --git a/dev-ruby/hashie/ChangeLog b/dev-ruby/hashie/ChangeLog
index 5ec43e65af45..dc50281a5d3c 100644
--- a/dev-ruby/hashie/ChangeLog
+++ b/dev-ruby/hashie/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/hashie
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hashie/ChangeLog,v 1.15 2012/08/14 00:00:01 flameeyes Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hashie/ChangeLog,v 1.16 2013/03/09 07:20:07 graaff Exp $
+
+*hashie-2.0.2 (09 Mar 2013)
+
+ 09 Mar 2013; Hans de Graaff <graaff@gentoo.org> +hashie-2.0.2.ebuild:
+ Version bump.
14 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org> hashie-1.2.0.ebuild:
Use the new rspec recipe for tests; bump to EAPI 4.
diff --git a/dev-ruby/hashie/hashie-2.0.2.ebuild b/dev-ruby/hashie/hashie-2.0.2.ebuild
new file mode 100644
index 000000000000..a6058464e2a6
--- /dev/null
+++ b/dev-ruby/hashie/hashie-2.0.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hashie/hashie-2.0.2.ebuild,v 1.1 2013/03/09 07:20:07 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19 jruby ree18"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hashie is a small collection of tools that make hashes more powerful."
+HOMEPAGE="http://intridea.com/posts/hashie-the-hash-toolkit"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # Remove bundler
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+}