summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-01-04 16:54:35 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-01-04 16:54:35 +0000
commitb1a034ffe3507e6d11cb982765d0a08908da73dc (patch)
tree3206f03495187e5fa14f36bbe1c594ff6d607364 /dev-ruby
parentDo not enable USE=gnome for verbiste and im-ja to avoid blocking gnome-3 update. (diff)
downloadgentoo-2-b1a034ffe3507e6d11cb982765d0a08908da73dc.tar.gz
gentoo-2-b1a034ffe3507e6d11cb982765d0a08908da73dc.tar.bz2
gentoo-2-b1a034ffe3507e6d11cb982765d0a08908da73dc.zip
Add ruby21 target.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/thread_safe/ChangeLog7
-rw-r--r--dev-ruby/thread_safe/thread_safe-0.1.3-r2.ebuild27
2 files changed, 33 insertions, 1 deletions
diff --git a/dev-ruby/thread_safe/ChangeLog b/dev-ruby/thread_safe/ChangeLog
index df476eaf0525..b2ae865274d4 100644
--- a/dev-ruby/thread_safe/ChangeLog
+++ b/dev-ruby/thread_safe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/thread_safe
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/thread_safe/ChangeLog,v 1.9 2014/01/04 16:20:38 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/thread_safe/ChangeLog,v 1.10 2014/01/04 16:54:35 mrueg Exp $
+
+*thread_safe-0.1.3-r2 (04 Jan 2014)
+
+ 04 Jan 2014; Manuel Rüger <mrueg@gentoo.org> +thread_safe-0.1.3-r2.ebuild:
+ Add ruby21 target.
04 Jan 2014; Manuel Rüger <mrueg@gentoo.org> -thread_safe-0.1.2.ebuild,
-thread_safe-0.1.3.ebuild:
diff --git a/dev-ruby/thread_safe/thread_safe-0.1.3-r2.ebuild b/dev-ruby/thread_safe/thread_safe-0.1.3-r2.ebuild
new file mode 100644
index 000000000000..a14a0f650e81
--- /dev/null
+++ b/dev-ruby/thread_safe/thread_safe-0.1.3-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/thread_safe/thread_safe-0.1.3-r2.ebuild,v 1.1 2014/01/04 16:54:35 mrueg Exp $
+
+EAPI=5
+# jruby → there is code for this in ext but that requires compiling java.
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A collection of thread-safe versions of common core Ruby classes"
+HOMEPAGE="https://github.com/headius/thread_safe"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~x86"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/atomic"
+
+each_ruby_prepare(){
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+}