summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-08-15 06:04:02 +0000
committerHans de Graaff <graaff@gentoo.org>2011-08-15 06:04:02 +0000
commitdb41745967574c86d533705935e4c6ad5a90585a (patch)
tree792b4a1d2cbac30e07ba9602822f3bed60a0220a /dev-ruby
parentRemove old versions. (diff)
downloadgentoo-2-db41745967574c86d533705935e4c6ad5a90585a.tar.gz
gentoo-2-db41745967574c86d533705935e4c6ad5a90585a.tar.bz2
gentoo-2-db41745967574c86d533705935e4c6ad5a90585a.zip
Version bump.
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/libxml/ChangeLog7
-rw-r--r--dev-ruby/libxml/libxml-2.2.1.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/dev-ruby/libxml/ChangeLog b/dev-ruby/libxml/ChangeLog
index 2678818232b6..070255b16acf 100644
--- a/dev-ruby/libxml/ChangeLog
+++ b/dev-ruby/libxml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/libxml
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/ChangeLog,v 1.51 2011/08/15 06:02:06 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/ChangeLog,v 1.52 2011/08/15 06:04:02 graaff Exp $
+
+*libxml-2.2.1 (15 Aug 2011)
+
+ 15 Aug 2011; Hans de Graaff <graaff@gentoo.org> +libxml-2.2.1.ebuild:
+ Version bump.
15 Aug 2011; Hans de Graaff <graaff@gentoo.org> -libxml-2.0.6.ebuild,
-libxml-2.0.9.ebuild, -libxml-2.1.2.ebuild:
diff --git a/dev-ruby/libxml/libxml-2.2.1.ebuild b/dev-ruby/libxml/libxml-2.2.1.ebuild
new file mode 100644
index 000000000000..2b22c87fe453
--- /dev/null
+++ b/dev-ruby/libxml/libxml-2.2.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/libxml-2.2.1.ebuild,v 1.1 2011/08/15 06:04:02 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_NAME="libxml-ruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc HISTORY"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby libxml with a user friendly API, akin to REXML, but feature complete and significantly faster."
+HOMEPAGE="http://libxml.rubyforge.org"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="${RDEPEND} dev-libs/libxml2"
+DEPEND="${DEPEND} dev-libs/libxml2"
+
+ruby_add_bdepend "doc? ( dev-ruby/rdoc )"
+
+all_ruby_prepare() {
+ # Remove grancher tasks only needed for publishing the website
+ sed -i -e '/grancher/d' -e '/Grancher/,$d' Rakefile || die
+
+ # We don't have the hanna template available.
+ sed -i -e 's/hanna/rake/' Rakefile || die
+
+ # Remove rake-compiler bits since we don't use it
+ sed -i -e '/extensiontask/d' -e '/ExtensionTask/,/end/d' -e '/GemPackageTask/,/end/d' Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -C ext/libxml extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -C ext/libxml
+ cp ext/libxml/libxml_ruby.so lib/ || die
+}
+
+each_ruby_test() {
+ # The test suite needs to load its files in alphabetical order but
+ # this is not guaranteed. See bug 370501.
+ ${RUBY} -Ilib -r test/test_helper.rb test/test_suite.rb || die
+}