summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2011-11-13 08:21:27 +0000
committerNaohiro Aota <naota@gentoo.org>2011-11-13 08:21:27 +0000
commitdbe73747f54fb96c3a1248f430242308d0a2822c (patch)
tree367fecf1b562c62104138858286d50b23563d9b6 /dev-ruby
parentBump, drop old. Notable changes: by default (i.e. when SOUP_SESSION_SSL_STRIC... (diff)
downloadgentoo-2-dbe73747f54fb96c3a1248f430242308d0a2822c.tar.gz
gentoo-2-dbe73747f54fb96c3a1248f430242308d0a2822c.tar.bz2
gentoo-2-dbe73747f54fb96c3a1248f430242308d0a2822c.zip
New ebuild dev-ruby/termcolor. ebuild written by Matsuu Takuto <matsuu@gentoo.org>
(Portage version: 2.2.0_alpha73/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/termcolor/ChangeLog11
-rw-r--r--dev-ruby/termcolor/Manifest4
-rw-r--r--dev-ruby/termcolor/metadata.xml8
-rw-r--r--dev-ruby/termcolor/termcolor-1.2.0.ebuild23
4 files changed, 46 insertions, 0 deletions
diff --git a/dev-ruby/termcolor/ChangeLog b/dev-ruby/termcolor/ChangeLog
new file mode 100644
index 000000000000..1f8724b78f85
--- /dev/null
+++ b/dev-ruby/termcolor/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-ruby/termcolor
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/termcolor/ChangeLog,v 1.1 2011/11/13 08:21:27 naota Exp $
+
+*termcolor-1.2.0 (13 Nov 2011)
+
+ 13 Nov 2011; Naohiro Aota <naota@gentoo.org> +termcolor-1.2.0.ebuild,
+ +metadata.xml:
+ New ebuild dev-ruby/termcolor. ebuild written by Matsuu Takuto
+ <matsuu@gentoo.org>
+
diff --git a/dev-ruby/termcolor/Manifest b/dev-ruby/termcolor/Manifest
new file mode 100644
index 000000000000..ed78c7090fd6
--- /dev/null
+++ b/dev-ruby/termcolor/Manifest
@@ -0,0 +1,4 @@
+DIST termcolor-1.2.0.gem 6656 RMD160 234b7c6e5fdae65febe9214442c66062908d91af SHA1 ccb19dc24757f5a2a27f948fe7bfc7a72e8a4601 SHA256 30b9f7c0f1834c2043a80d7d739e8fcf14303bed0244cb56e3a4676608bf8b67
+EBUILD termcolor-1.2.0.ebuild 613 RMD160 7a6fdfdee57673e7823cf592f2a5dfd1935d56f8 SHA1 6adee574a18a26d1d87e6a2898d46bffce973739 SHA256 a186378760bf67ddd699fb9f175e72cf765ef18e3cc4b5ad85f0b238498245f1
+MISC ChangeLog 328 RMD160 3a782fa4079c803d5dc8d546f3d5d379874b9f34 SHA1 c0a251ea786a3586e662c1317d1d2e0bf04921ea SHA256 65fe74e70b5e91d013b181e0c80629b141ad6737a2d7fc77c385b12555427c1a
+MISC metadata.xml 220 RMD160 7f7779deaa0be13dd0c2a42a0f368c1f427322db SHA1 f76b9fa76642a7c943c52c815428c15b4f844cfb SHA256 3876bf94339a6b2a36040fdf7eaeb1dcddff46924c02b8135f615c2d4eb1c743
diff --git a/dev-ruby/termcolor/metadata.xml b/dev-ruby/termcolor/metadata.xml
new file mode 100644
index 000000000000..61f90007fbc3
--- /dev/null
+++ b/dev-ruby/termcolor/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+<maintainer>
+ <email>naota@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-ruby/termcolor/termcolor-1.2.0.ebuild b/dev-ruby/termcolor/termcolor-1.2.0.ebuild
new file mode 100644
index 000000000000..b6a2d7f41c79
--- /dev/null
+++ b/dev-ruby/termcolor/termcolor-1.2.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/termcolor/termcolor-1.2.0.ebuild,v 1.1 2011/11/13 08:21:27 naota Exp $
+
+EAPI="2"
+#*** Using highline effectively in JRuby requires manually installing the ffi-ncurses gem.
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="a library for ANSI color formatting like HTML for output in terminal"
+HOMEPAGE="http://termcolor.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend dev-ruby/rspec
+ruby_add_rdepend ">=dev-ruby/highline-1.5.0"