summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-02-02 07:06:15 +0000
committerHans de Graaff <graaff@gentoo.org>2011-02-02 07:06:15 +0000
commite4ffbeaef1ef5093cea62f0097d939c1ff6382f8 (patch)
tree803fbe6fca7fb0858471cff6eedd367b6f17fa3c /dev-ruby
parentRemove extra escapes. Stable for HPPA (bug #350730). (diff)
downloadgentoo-2-e4ffbeaef1ef5093cea62f0097d939c1ff6382f8.tar.gz
gentoo-2-e4ffbeaef1ef5093cea62f0097d939c1ff6382f8.tar.bz2
gentoo-2-e4ffbeaef1ef5093cea62f0097d939c1ff6382f8.zip
Version bump.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/hoe/ChangeLog7
-rw-r--r--dev-ruby/hoe/hoe-2.9.0.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-ruby/hoe/ChangeLog b/dev-ruby/hoe/ChangeLog
index 17e76b9d874a..a66f8c5f98bc 100644
--- a/dev-ruby/hoe/ChangeLog
+++ b/dev-ruby/hoe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/hoe
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/ChangeLog,v 1.102 2011/01/16 09:48:22 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/ChangeLog,v 1.103 2011/02/02 07:06:15 graaff Exp $
+
+*hoe-2.9.0 (02 Feb 2011)
+
+ 02 Feb 2011; Hans de Graaff <graaff@gentoo.org> +hoe-2.9.0.ebuild:
+ Version bump.
16 Jan 2011; Markos Chandras <hwoarang@gentoo.org> hoe-2.6.0-r1.ebuild:
Stable on amd64 wrt bug #333947
diff --git a/dev-ruby/hoe/hoe-2.9.0.ebuild b/dev-ruby/hoe/hoe-2.9.0.ebuild
new file mode 100644
index 000000000000..e7acf18e27da
--- /dev/null
+++ b/dev-ruby/hoe/hoe-2.9.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/hoe-2.9.0.ebuild,v 1.1 2011/02/02 07:06:15 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt Manifest.txt README.txt"
+
+RUBY_FAKEGEM_EXTRAINSTALL="template"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hoe extends rake to provide full project automation."
+HOMEPAGE="http://seattlerb.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+#RUBY_PATCHES=( "${P}-test-file-ordering.patch" )
+
+# - also requires dev-ruby/hoe-seattlerb for 1.9;
+# - dev-ruby/gemcutter is an optional dependency at both runtime and
+# test-time, at least for us;
+# - rubyforge is loaded at runtime when needed, so we don't strictly
+# depend on it at runtime, but we need it for tests (for now);
+ruby_add_bdepend "test? ( dev-ruby/minitest >=dev-ruby/rubyforge-2.0.4 )"
+
+ruby_add_rdepend ">=dev-ruby/rake-0.8.7"