summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-04-22 07:44:41 +0000
committerHans de Graaff <graaff@gentoo.org>2012-04-22 07:44:41 +0000
commitf5953d69ecc3f8d0faa8050b136fe3cc3d29fd53 (patch)
tree45aa4c4cad50c6ce1d245637f44b72306b36e711 /dev-ruby
parentMask x11-apps/xsetmode & x11-apps/xsetpointer for removal wrt bug #411999. (diff)
downloadgentoo-2-f5953d69ecc3f8d0faa8050b136fe3cc3d29fd53.tar.gz
gentoo-2-f5953d69ecc3f8d0faa8050b136fe3cc3d29fd53.tar.bz2
gentoo-2-f5953d69ecc3f8d0faa8050b136fe3cc3d29fd53.zip
Version bump.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/yard/ChangeLog7
-rw-r--r--dev-ruby/yard/yard-0.7.5.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-ruby/yard/ChangeLog b/dev-ruby/yard/ChangeLog
index f9ea797caae9..a6d2dabbc6ac 100644
--- a/dev-ruby/yard/ChangeLog
+++ b/dev-ruby/yard/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/yard
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/yard/ChangeLog,v 1.27 2012/03/02 16:41:37 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/yard/ChangeLog,v 1.28 2012/04/22 07:44:41 graaff Exp $
+
+*yard-0.7.5 (22 Apr 2012)
+
+ 22 Apr 2012; Hans de Graaff <graaff@gentoo.org> +yard-0.7.5.ebuild:
+ Version bump.
02 Mar 2012; Naohiro Aota <naota@gentoo.org> yard-0.7.4.ebuild:
Add ~x86-fbsd
diff --git a/dev-ruby/yard/yard-0.7.5.ebuild b/dev-ruby/yard/yard-0.7.5.ebuild
new file mode 100644
index 000000000000..f35f612ecfae
--- /dev/null
+++ b/dev-ruby/yard/yard-0.7.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/yard/yard-0.7.5.ebuild,v 1.1 2012/04/22 07:44:41 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="specs"
+RUBY_FAKEGEM_TASK_DOC="yard"
+
+RUBY_FAKEGEM_EXTRADOC="README.md ChangeLog"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="templates"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Documentation generation tool for the Ruby programming language"
+HOMEPAGE="http://yardoc.org/"
+
+LICENSE="as-is" # truly
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "doc? ( || ( dev-ruby/bluecloth dev-ruby/maruku dev-ruby/rdiscount dev-ruby/kramdown ) )"
+ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *jruby)
+ # This spec requires rdiscount which is a C extension.
+ sed -i -e '145s/should/should_not/' spec/templates/helpers/html_helper_spec.rb || die
+ ;;
+ *)
+ ;;
+ esac
+}