summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-05-31 06:07:54 +0000
committerHans de Graaff <graaff@gentoo.org>2010-05-31 06:07:54 +0000
commitfa9b13beb87a77681a8b413d14e5534f01f17c01 (patch)
treec1c6444365424cdfe8ab7a299eb94eb126cb23e8 /dev-ruby
parentBump for Rails 2.3.8. Drop ppc/ppc64 keywords due to new unkeyworded dependency. (diff)
downloadgentoo-2-fa9b13beb87a77681a8b413d14e5534f01f17c01.tar.gz
gentoo-2-fa9b13beb87a77681a8b413d14e5534f01f17c01.tar.bz2
gentoo-2-fa9b13beb87a77681a8b413d14e5534f01f17c01.zip
Bump for Rails 2.3.8. Drop ppc/ppc64 keywords due to new unkeyworded dependency.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/activerecord/ChangeLog9
-rw-r--r--dev-ruby/activerecord/activerecord-2.3.8.ebuild52
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-ruby/activerecord/ChangeLog b/dev-ruby/activerecord/ChangeLog
index a6418a5aca1e..e706221f9a92 100644
--- a/dev-ruby/activerecord/ChangeLog
+++ b/dev-ruby/activerecord/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/activerecord
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.134 2010/05/23 10:37:02 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.135 2010/05/31 06:07:54 graaff Exp $
+
+*activerecord-2.3.8 (31 May 2010)
+
+ 31 May 2010; Hans de Graaff <graaff@gentoo.org>
+ +activerecord-2.3.8.ebuild:
+ Bump for Rails 2.3.8. Drop ppc/ppc64 keywords due to new unkeyworded
+ dependency.
23 May 2010; Alex Legler <a3li@gentoo.org> activerecord-2.3.5-r1.ebuild:
Add REE18 support
diff --git a/dev-ruby/activerecord/activerecord-2.3.8.ebuild b/dev-ruby/activerecord/activerecord-2.3.8.ebuild
new file mode 100644
index 000000000000..89b96af3628a
--- /dev/null
+++ b/dev-ruby/activerecord/activerecord-2.3.8.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-2.3.8.ebuild,v 1.1 2010/05/31 06:07:54 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 jruby"
+
+# this is not null so that the dependencies will actually be filled
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
+HOMEPAGE="http://rubyforge.org/projects/activerecord/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="mysql postgres sqlite3" #sqlite
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}"
+
+#ruby_add_rdepend sqlite ">=dev-ruby/sqlite-ruby-2.2.2"
+USE_RUBY=ruby18 ruby_add_rdepend "ruby_targets_ruby18 sqlite3" "dev-ruby/sqlite3-ruby"
+USE_RUBY=ruby18 ruby_add_rdepend "ruby_targets_ruby18 mysql" ">=dev-ruby/mysql-ruby-2.7"
+USE_RUBY=ruby18 ruby_add_rdepend "ruby_targets_ruby18 postgres" "dev-ruby/pg"
+
+ruby_add_bdepend test ">=dev-ruby/mocha-0.9.5 virtual/ruby-test-unit"
+
+all_ruby_prepare() {
+ # Custom template not found in package
+ sed -i -e '/horo/d' Rakefile || die
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *jruby)
+ ;;
+ *)
+ if use sqlite3; then
+ ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
+ fi
+ ;;
+ esac
+#
+# if use sqlite; then
+# ${RUBY} -S rake test_sqlite || die "sqlite3 tests failed"
+# fi
+}