summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2007-12-17 21:32:54 +0000
committerMarijn Schouten <hkbst@gentoo.org>2007-12-17 21:32:54 +0000
commit57180e5665d9709dca7b311efb907beb285d0490 (patch)
tree93e24ae3b558055b8e608c455384547f72569b31 /dev-scheme/gambit
parentno need to dodoc the license (diff)
downloadgentoo-2-57180e5665d9709dca7b311efb907beb285d0490.tar.gz
gentoo-2-57180e5665d9709dca7b311efb907beb285d0490.tar.bz2
gentoo-2-57180e5665d9709dca7b311efb907beb285d0490.zip
bump
(Portage version: 2.1.4_rc10)
Diffstat (limited to 'dev-scheme/gambit')
-rw-r--r--dev-scheme/gambit/ChangeLog7
-rw-r--r--dev-scheme/gambit/files/digest-gambit-4.1.23
-rw-r--r--dev-scheme/gambit/gambit-4.1.2.ebuild102
3 files changed, 111 insertions, 1 deletions
diff --git a/dev-scheme/gambit/ChangeLog b/dev-scheme/gambit/ChangeLog
index ec0b69e96e81..8816c58c047c 100644
--- a/dev-scheme/gambit/ChangeLog
+++ b/dev-scheme/gambit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-scheme/gambit
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/ChangeLog,v 1.15 2007/12/16 13:01:23 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/ChangeLog,v 1.16 2007/12/17 21:32:54 hkbst Exp $
+
+*gambit-4.1.2 (17 Dec 2007)
+
+ 17 Dec 2007; Marijn Schouten <hkBst@gentoo.org> +gambit-4.1.2.ebuild:
+ bump
*gambit-4.1.1 (16 Dec 2007)
diff --git a/dev-scheme/gambit/files/digest-gambit-4.1.2 b/dev-scheme/gambit/files/digest-gambit-4.1.2
new file mode 100644
index 000000000000..610a5c5a5021
--- /dev/null
+++ b/dev-scheme/gambit/files/digest-gambit-4.1.2
@@ -0,0 +1,3 @@
+MD5 2838dc47f73e22f9d5da11e79a01d63c gambc-v4_1_2.tgz 11986578
+RMD160 645366cffbc0375ffb2c4d0ccad1359385dd4820 gambc-v4_1_2.tgz 11986578
+SHA256 16158e0ce3d79bb23039e9c429971dff3baef944582198d27df52a0b3808a4ea gambc-v4_1_2.tgz 11986578
diff --git a/dev-scheme/gambit/gambit-4.1.2.ebuild b/dev-scheme/gambit/gambit-4.1.2.ebuild
new file mode 100644
index 000000000000..4a1bf18f21fa
--- /dev/null
+++ b/dev-scheme/gambit/gambit-4.1.2.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.1.2.ebuild,v 1.1 2007/12/17 21:32:54 hkbst Exp $
+
+inherit eutils elisp-common check-reqs autotools multilib
+
+MY_PN=gambc
+MY_PV=${PV//./_}
+MY_P=${MY_PN}-v${MY_PV}
+
+DESCRIPTION="Gambit-C is a native Scheme to C compiler and interpreter."
+HOMEPAGE="http://www.iro.umontreal.ca/~gambit/"
+SRC_URI="http://www.iro.umontreal.ca/~gambit/download/gambit/v${PV%.*}/source/${MY_P}.tgz"
+
+LICENSE="|| ( Apache-2.0 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND="emacs? ( virtual/emacs )"
+
+SITEFILE="50gambit-gentoo.el"
+
+S=${WORKDIR}/${MY_P}
+
+IUSE="big-iron emacs static"
+
+pkg_setup() {
+ if ! use big-iron; then
+ ewarn "NOT compiling each Scheme module as a single C function"
+ ewarn "NOT using gcc specific optimizations"
+ ewarn "approximately 0.5GB ram will be needed"
+ ewarn "if you experience thrashing, try disabling parallel building or setting -O1"
+ # need this much memory in MBytes (does *not* check swap)
+ CHECKREQS_MEMORY="768" check_reqs
+ else
+ ewarn "compiling each Scheme module as a single C function"
+ ewarn "using gcc specific optimizations"
+ ewarn "approximately 2GB ram will be needed instead of 0.5GB"
+ ewarn "this will cause heavy thrashing of your system"
+ ewarn "and may cause your compiler to crash when it runs out of memory"
+ ewarn "unless your system is BIG IRON"
+ # need this much memory in MBytes (does *not* check swap)
+ CHECKREQS_MEMORY="2560" check_reqs
+ fi
+}
+
+src_unpack() {
+ unpack ${A}; cd "${S}"
+# cp configure.ac configure.ac.old
+ sed -e 's:PACKAGE_SUBDIR="/$PACKAGE_VERSION"::' \
+ -e 's:#PACKAGE_SUBDIR="":PACKAGE_SUBDIR="":' -i configure.ac
+ #don't force -O1
+ sed 's:$DASH_O1::' -i configure.ac
+ eautoreconf
+# diff -u configure.ac.old configure.ac
+}
+
+src_compile() {
+ econf $(use_enable !static shared) $(use_enable big-iron single-host) $(use_enable big-iron gcc-opts)
+
+ emake || die "emake failed"
+
+ if use emacs; then
+ ( cd misc; elisp-comp *.el )
+ fi
+}
+
+src_install() {
+ einstall docdir="${D}"/usr/share/doc/${PF} || die "einstall failed"
+
+ rm "${D}"/usr/current
+
+ mv "${D}"/usr/syntax-case.scm "${D}"/usr/$(get_libdir)
+
+ # rename the /usr/bin/gsc to avoid collision with gsc from ghostscript
+ mv "${D}"/usr/bin/gsc "${D}"/usr/bin/gsc-gambit
+
+ # remove emacs/site-lisp/gambit.el
+ rm -r "${D}"/usr/share/emacs
+ if use emacs; then
+ elisp-install ${PN} misc/*.{el,elc}
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ fi
+
+ dodoc INSTALL.txt README
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+
+ # create some more explicit names
+ dosym gsc-gambit usr/bin/gambit-compiler
+ dosym gsi usr/bin/gambit-interpreter
+
+ echo "GAMBCOPT=\"=/usr/\"" > "${T}"/50gambit && doenvd "${T}"/50gambit
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}