summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2012-01-24 14:08:41 +0000
committerMarijn Schouten <hkbst@gentoo.org>2012-01-24 14:08:41 +0000
commita59267ba8ead0809375f3d35b5d5e03027e7cfe5 (patch)
treec28baacb900b934553fdbf7ab41da6ead59abdf5 /dev-scheme
parentReplace bad copy of proc mem handling patch (diff)
downloadgentoo-2-a59267ba8ead0809375f3d35b5d5e03027e7cfe5.tar.gz
gentoo-2-a59267ba8ead0809375f3d35b5d5e03027e7cfe5.tar.bz2
gentoo-2-a59267ba8ead0809375f3d35b5d5e03027e7cfe5.zip
bump and clean up
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'dev-scheme')
-rw-r--r--dev-scheme/gambit/ChangeLog12
-rw-r--r--dev-scheme/gambit/gambit-4.4.0.ebuild94
-rw-r--r--dev-scheme/gambit/gambit-4.4.1.ebuild55
-rw-r--r--dev-scheme/gambit/gambit-4.4.2.ebuild52
-rw-r--r--dev-scheme/gambit/gambit-4.4.3.ebuild52
-rw-r--r--dev-scheme/gambit/gambit-4.5.1.ebuild52
-rw-r--r--dev-scheme/gambit/gambit-4.5.2.ebuild52
-rw-r--r--dev-scheme/gambit/gambit-4.5.3.ebuild52
-rw-r--r--dev-scheme/gambit/gambit-4.6.3.ebuild (renamed from dev-scheme/gambit/gambit-4.5.3-r1.ebuild)12
9 files changed, 14 insertions, 419 deletions
diff --git a/dev-scheme/gambit/ChangeLog b/dev-scheme/gambit/ChangeLog
index e0b4480bdf83..87540cc076f8 100644
--- a/dev-scheme/gambit/ChangeLog
+++ b/dev-scheme/gambit/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-scheme/gambit
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/ChangeLog,v 1.34 2011/10/19 13:45:37 hkbst Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/ChangeLog,v 1.35 2012/01/24 14:08:41 hkbst Exp $
+
+*gambit-4.6.3 (24 Jan 2012)
+
+ 24 Jan 2012; <marijn@gentoo.org> -gambit-4.4.0.ebuild, -gambit-4.4.1.ebuild,
+ -gambit-4.4.2.ebuild, -gambit-4.4.3.ebuild, -gambit-4.5.1.ebuild,
+ -gambit-4.5.2.ebuild, -gambit-4.5.3.ebuild, -gambit-4.5.3-r1.ebuild,
+ +gambit-4.6.3.ebuild:
+ bump and clean up
*gambit-4.6.2 (19 Oct 2011)
diff --git a/dev-scheme/gambit/gambit-4.4.0.ebuild b/dev-scheme/gambit/gambit-4.4.0.ebuild
deleted file mode 100644
index 1a1738e66373..000000000000
--- a/dev-scheme/gambit/gambit-4.4.0.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.4.0.ebuild,v 1.4 2009/01/28 16:46:59 hkbst Exp $
-
-inherit eutils elisp-common check-reqs multilib
-
-MY_PN=gambc
-MY_PV=${PV//./_}
-MY_P=${MY_PN}-v${MY_PV}
-
-DESCRIPTION="Gambit-C is a native Scheme to C compiler and interpreter."
-HOMEPAGE="http://www.iro.umontreal.ca/~gambit/"
-SRC_URI="http://www.iro.umontreal.ca/~gambit/download/gambit/v${PV%.*}/source/${MY_P}.tgz"
-
-LICENSE="|| ( Apache-2.0 LGPL-2.1 )"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-
-DEPEND="emacs? ( virtual/emacs )"
-RDEPEND=""
-
-SITEFILE="50gambit-gentoo.el"
-
-S=${WORKDIR}/${MY_P} #-devel
-
-IUSE="emacs static"
-
-_pkg_setup() {
- if use big-iron; then
- ewarn "compiling each Scheme module as a single C function"
- ewarn "using gcc specific optimizations"
- ewarn "approximately 2GB ram will be needed instead of 0.5GB"
- ewarn "this will cause heavy thrashing of your system"
- ewarn "and may cause your compiler to crash when it runs out of memory"
- ewarn "unless your system is BIG IRON"
- # need this much memory in MBytes (does *not* check swap)
- CHECKREQS_MEMORY="2560" check_reqs
- else
- ewarn "NOT compiling each Scheme module as a single C function"
- ewarn "NOT using gcc specific optimizations"
- ewarn "approximately 0.5GB ram will be needed"
- ewarn "if you experience thrashing, try disabling parallel building or setting -O1"
- # need this much memory in MBytes (does *not* check swap)
- CHECKREQS_MEMORY="768" check_reqs
- fi
-}
-
-src_compile() {
- econf $(use_enable !static shared) --enable-single-host --disable-absolute-shared-libs
-
- emake bootstrap || die
-
- if use emacs; then
- elisp-compile misc/*.el || die
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- # rename the /usr/bin/gsc to avoid collision with gsc from ghostscript
- mv "${D}"/usr/bin/gsc "${D}"/usr/bin/gsc-gambit
-}
-
-_src_install(){
- rm "${D}"/usr/current
-
- mv "${D}"/usr/syntax-case.scm "${D}"/usr/$(get_libdir)
-
- # remove emacs/site-lisp/gambit.el
- rm -r "${D}"/usr/share/emacs
- if use emacs; then
- elisp-install ${PN} misc/*.{el,elc}
- elisp-site-file-install "${FILESDIR}"/${SITEFILE}
- fi
-
- dodoc INSTALL.txt README
- insinto /usr/share/doc/${PF}
- doins -r examples
-
- # create some more explicit names
- dosym gsc-gambit usr/bin/gambit-compiler
- dosym gsi usr/bin/gambit-interpreter
-
- echo "GAMBCOPT=\"=/usr/\"" > "${T}"/50gambit && doenvd "${T}"/50gambit
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-scheme/gambit/gambit-4.4.1.ebuild b/dev-scheme/gambit/gambit-4.4.1.ebuild
deleted file mode 100644
index e66dd9ea6242..000000000000
--- a/dev-scheme/gambit/gambit-4.4.1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.4.1.ebuild,v 1.2 2009/05/26 06:09:44 pva Exp $
-
-inherit eutils elisp-common check-reqs multilib
-
-MY_PN=gambc
-MY_PV=${PV//./_}
-MY_P=${MY_PN}-v${MY_PV}
-
-DESCRIPTION="Gambit-C is a native Scheme to C compiler and interpreter."
-HOMEPAGE="http://www.iro.umontreal.ca/~gambit/"
-SRC_URI="http://www.iro.umontreal.ca/~gambit/download/gambit/v${PV%.*}/source/${MY_P}.tgz"
-
-LICENSE="|| ( Apache-2.0 LGPL-2.1 )"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-
-#gsc is now Gambit Scheme Compile and not ghostscript.
-#only app-text/ghostscript-gpl-8.64 has freed gsc yet.
-DEPEND="emacs? ( virtual/emacs )
- !app-text/ghostscript-gnu
- !<app-text/ghostscript-gpl-8.64"
-RDEPEND=""
-
-SITEFILE="50gambit-gentoo.el"
-
-S=${WORKDIR}/${MY_P} #-devel
-
-IUSE="emacs static"
-
-src_compile() {
- econf $(use_enable !static shared) --enable-single-host --disable-absolute-shared-libs
-
- emake bootstrap || die
-
- if use emacs; then
- elisp-compile misc/*.el || die
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
-# # rename the /usr/bin/gsc to avoid collision with gsc from ghostscript
-# mv "${D}"/usr/bin/gsc "${D}"/usr/bin/gsc-gambit
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-scheme/gambit/gambit-4.4.2.ebuild b/dev-scheme/gambit/gambit-4.4.2.ebuild
deleted file mode 100644
index 3a1cd3f840db..000000000000
--- a/dev-scheme/gambit/gambit-4.4.2.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.4.2.ebuild,v 1.2 2009/05/26 06:09:44 pva Exp $
-
-inherit elisp-common
-
-MY_PN=gambc
-MY_PV=${PV//./_}
-MY_P=${MY_PN}-v${MY_PV}
-
-DESCRIPTION="Gambit-C is a native Scheme to C compiler and interpreter."
-HOMEPAGE="http://www.iro.umontreal.ca/~gambit/"
-SRC_URI="http://www.iro.umontreal.ca/~gambit/download/gambit/v${PV%.*}/source/${MY_P}.tgz"
-
-LICENSE="|| ( Apache-2.0 LGPL-2.1 )"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-
-#gsc is now Gambit Scheme Compile and not ghostscript.
-#only app-text/ghostscript-gpl-8.64 has freed gsc yet.
-DEPEND="emacs? ( virtual/emacs )
- !app-text/ghostscript-gnu
- !<app-text/ghostscript-gpl-8.64"
-RDEPEND=""
-
-SITEFILE="50gambit-gentoo.el"
-
-S=${WORKDIR}/${MY_P} #-devel
-
-IUSE="emacs static"
-
-src_compile() {
- econf $(use_enable !static shared) --docdir=/usr/share/doc/${PF} --enable-single-host --disable-absolute-shared-libs
-
- emake bootstrap || die
-
- if use emacs; then
- elisp-compile misc/*.el || die
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-scheme/gambit/gambit-4.4.3.ebuild b/dev-scheme/gambit/gambit-4.4.3.ebuild
deleted file mode 100644
index 9e6d9668d5dc..000000000000
--- a/dev-scheme/gambit/gambit-4.4.3.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.4.3.ebuild,v 1.2 2009/05/26 06:09:44 pva Exp $
-
-inherit elisp-common
-
-MY_PN=gambc
-MY_PV=${PV//./_}
-MY_P=${MY_PN}-v${MY_PV}
-
-DESCRIPTION="Gambit-C is a native Scheme to C compiler and interpreter."
-HOMEPAGE="http://www.iro.umontreal.ca/~gambit/"
-SRC_URI="http://www.iro.umontreal.ca/~gambit/download/gambit/v${PV%.*}/source/${MY_P}.tgz"
-
-LICENSE="|| ( Apache-2.0 LGPL-2.1 )"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-
-#gsc is now Gambit Scheme Compiler and not ghostscript.
-#only app-text/ghostscript-gpl-8.64 has freed gsc yet.
-DEPEND="emacs? ( virtual/emacs )
- !app-text/ghostscript-gnu
- !<app-text/ghostscript-gpl-8.64"
-RDEPEND=""
-
-SITEFILE="50gambit-gentoo.el"
-
-S=${WORKDIR}/${MY_P} #-devel
-
-IUSE="emacs static"
-
-src_compile() {
- econf $(use_enable !static shared) --docdir=/usr/share/doc/${PF} --enable-single-host --disable-absolute-shared-libs
-
- emake bootstrap || die
-
- if use emacs; then
- elisp-compile misc/*.el || die
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-scheme/gambit/gambit-4.5.1.ebuild b/dev-scheme/gambit/gambit-4.5.1.ebuild
deleted file mode 100644
index cc50c3e017d0..000000000000
--- a/dev-scheme/gambit/gambit-4.5.1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.5.1.ebuild,v 1.1 2009/08/07 13:20:05 hkbst Exp $
-
-inherit elisp-common
-
-MY_PN=gambc
-MY_PV=${PV//./_}
-MY_P=${MY_PN}-v${MY_PV}
-
-DESCRIPTION="Gambit-C is a native Scheme to C compiler and interpreter."
-HOMEPAGE="http://www.iro.umontreal.ca/~gambit/"
-SRC_URI="http://www.iro.umontreal.ca/~gambit/download/gambit/v${PV%.*}/source/${MY_P}.tgz"
-
-LICENSE="|| ( Apache-2.0 LGPL-2.1 )"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-
-#gsc is now Gambit Scheme Compiler and not ghostscript.
-#only app-text/ghostscript-gpl-8.64 has freed gsc yet.
-DEPEND="emacs? ( virtual/emacs )
- !app-text/ghostscript-gnu
- !<app-text/ghostscript-gpl-8.64"
-RDEPEND=""
-
-SITEFILE="50gambit-gentoo.el"
-
-S=${WORKDIR}/${MY_P} #-devel
-
-IUSE="emacs static"
-
-src_compile() {
- econf $(use_enable !static shared) --docdir=/usr/share/doc/${PF} --enable-single-host --disable-absolute-shared-libs
-
- emake bootstrap || die
-
- if use emacs; then
- elisp-compile misc/*.el || die
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-scheme/gambit/gambit-4.5.2.ebuild b/dev-scheme/gambit/gambit-4.5.2.ebuild
deleted file mode 100644
index cb7b60fe0352..000000000000
--- a/dev-scheme/gambit/gambit-4.5.2.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.5.2.ebuild,v 1.1 2009/09/11 15:28:02 hkbst Exp $
-
-inherit elisp-common
-
-MY_PN=gambc
-MY_PV=${PV//./_}
-MY_P=${MY_PN}-v${MY_PV}
-
-DESCRIPTION="Gambit-C is a native Scheme to C compiler and interpreter."
-HOMEPAGE="http://www.iro.umontreal.ca/~gambit/"
-SRC_URI="http://www.iro.umontreal.ca/~gambit/download/gambit/v${PV%.*}/source/${MY_P}.tgz"
-
-LICENSE="|| ( Apache-2.0 LGPL-2.1 )"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-
-#gsc is now Gambit Scheme Compiler and not ghostscript.
-#only app-text/ghostscript-gpl-8.64 has freed gsc yet.
-DEPEND="emacs? ( virtual/emacs )
- !app-text/ghostscript-gnu
- !<app-text/ghostscript-gpl-8.64"
-RDEPEND=""
-
-SITEFILE="50gambit-gentoo.el"
-
-S=${WORKDIR}/${MY_P} #-devel
-
-IUSE="emacs static"
-
-src_compile() {
- econf $(use_enable !static shared) --docdir=/usr/share/doc/${PF} --enable-single-host --disable-absolute-shared-libs
-
- emake bootstrap || die
-
- if use emacs; then
- elisp-compile misc/*.el || die
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-scheme/gambit/gambit-4.5.3.ebuild b/dev-scheme/gambit/gambit-4.5.3.ebuild
deleted file mode 100644
index 1261dc134997..000000000000
--- a/dev-scheme/gambit/gambit-4.5.3.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.5.3.ebuild,v 1.1 2009/11/02 15:09:06 hkbst Exp $
-
-inherit elisp-common
-
-MY_PN=gambc
-MY_PV=${PV//./_}
-MY_P=${MY_PN}-v${MY_PV}
-
-DESCRIPTION="Gambit-C is a native Scheme to C compiler and interpreter."
-HOMEPAGE="http://www.iro.umontreal.ca/~gambit/"
-SRC_URI="http://www.iro.umontreal.ca/~gambit/download/gambit/v${PV%.*}/source/${MY_P}.tgz"
-
-LICENSE="|| ( Apache-2.0 LGPL-2.1 )"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-
-#gsc is now Gambit Scheme Compiler and not ghostscript.
-#only app-text/ghostscript-gpl-8.64 has freed gsc yet.
-DEPEND="emacs? ( virtual/emacs )
- !app-text/ghostscript-gnu
- !<app-text/ghostscript-gpl-8.64"
-RDEPEND=""
-
-SITEFILE="50gambit-gentoo.el"
-
-S=${WORKDIR}/${MY_P} #-devel
-
-IUSE="emacs static"
-
-src_compile() {
- econf $(use_enable !static shared) --docdir=/usr/share/doc/${PF} --enable-single-host --disable-absolute-shared-libs
-
- emake bootstrap || die
-
- if use emacs; then
- elisp-compile misc/*.el || die
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-scheme/gambit/gambit-4.5.3-r1.ebuild b/dev-scheme/gambit/gambit-4.6.3.ebuild
index 4814faa1e8f6..ff537aa76a5f 100644
--- a/dev-scheme/gambit/gambit-4.5.3-r1.ebuild
+++ b/dev-scheme/gambit/gambit-4.6.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.5.3-r1.ebuild,v 1.3 2010/11/18 12:16:14 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.6.3.ebuild,v 1.1 2012/01/24 14:08:41 hkbst Exp $
-EAPI="3"
+EAPI="4"
inherit eutils elisp-common
@@ -18,11 +18,7 @@ LICENSE="|| ( Apache-2.0 LGPL-2.1 )"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-macos"
-#gsc is now Gambit Scheme Compiler and not ghostscript.
-#only app-text/ghostscript-gpl-8.64 has freed gsc yet.
-DEPEND="emacs? ( virtual/emacs )
- !app-text/ghostscript-gnu
- !<app-text/ghostscript-gpl-8.64"
+DEPEND="emacs? ( virtual/emacs )"
RDEPEND=""
SITEFILE="50gambit-gentoo.el"