summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-08-28 17:49:25 +0000
committerUlrich Müller <ulm@gentoo.org>2008-08-28 17:49:25 +0000
commitd612410436d085ffac6682892a9cb2532b6390ae (patch)
tree2495775a4c7ee0bcecc22db88b41f9cb81b4777e /dev-scheme
parentMarked stable on amd64 (diff)
downloadgentoo-2-d612410436d085ffac6682892a9cb2532b6390ae.tar.gz
gentoo-2-d612410436d085ffac6682892a9cb2532b6390ae.tar.bz2
gentoo-2-d612410436d085ffac6682892a9cb2532b6390ae.zip
Use elisp-compile instead of elisp-comp. Install Emacs byte-code files. Fixes bug 235881.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo-r1 i686)
Diffstat (limited to 'dev-scheme')
-rw-r--r--dev-scheme/bigloo/ChangeLog9
-rw-r--r--dev-scheme/bigloo/bigloo-2.7a_p2.ebuild6
-rw-r--r--dev-scheme/bigloo/bigloo-2.9a.ebuild10
-rw-r--r--dev-scheme/bigloo/bigloo-3.0a_p2.ebuild10
-rw-r--r--dev-scheme/bigloo/bigloo-3.0b.ebuild10
-rw-r--r--dev-scheme/bigloo/bigloo-3.0b_p2.ebuild10
-rw-r--r--dev-scheme/bigloo/bigloo-3.0c.ebuild10
-rw-r--r--dev-scheme/bigloo/bigloo-3.0c_p4.ebuild8
-rw-r--r--dev-scheme/bigloo/bigloo-3.1a.ebuild8
9 files changed, 51 insertions, 30 deletions
diff --git a/dev-scheme/bigloo/ChangeLog b/dev-scheme/bigloo/ChangeLog
index 1e6abc5e2c25..117af7e4074b 100644
--- a/dev-scheme/bigloo/ChangeLog
+++ b/dev-scheme/bigloo/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-scheme/bigloo
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/bigloo/ChangeLog,v 1.26 2008/06/03 10:12:53 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/bigloo/ChangeLog,v 1.27 2008/08/28 17:49:25 ulm Exp $
+
+ 28 Aug 2008; Ulrich Mueller <ulm@gentoo.org> bigloo-2.7a_p2.ebuild,
+ bigloo-2.9a.ebuild, bigloo-3.0a_p2.ebuild, bigloo-3.0b.ebuild,
+ bigloo-3.0b_p2.ebuild, bigloo-3.0c.ebuild, bigloo-3.0c_p4.ebuild,
+ bigloo-3.1a.ebuild:
+ Use elisp-compile instead of elisp-comp. Install Emacs byte-code files.
+ Fixes bug 235881.
*bigloo-3.1a (03 Jun 2008)
diff --git a/dev-scheme/bigloo/bigloo-2.7a_p2.ebuild b/dev-scheme/bigloo/bigloo-2.7a_p2.ebuild
index d214378e56e7..8425da62ded8 100644
--- a/dev-scheme/bigloo/bigloo-2.7a_p2.ebuild
+++ b/dev-scheme/bigloo/bigloo-2.7a_p2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/bigloo/bigloo-2.7a_p2.ebuild,v 1.5 2007/06/22 10:59:55 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/bigloo/bigloo-2.7a_p2.ebuild,v 1.6 2008/08/28 17:49:25 ulm Exp $
inherit elisp-common
@@ -51,7 +51,7 @@ src_compile() {
make || die
if use emacs; then
- pushd etc; elisp-comp *.el; popd
+ elisp-compile etc/*.el || die "elisp-compile failed"
fi
}
diff --git a/dev-scheme/bigloo/bigloo-2.9a.ebuild b/dev-scheme/bigloo/bigloo-2.9a.ebuild
index 18a05ea36ff5..29cc93103c87 100644
--- a/dev-scheme/bigloo/bigloo-2.9a.ebuild
+++ b/dev-scheme/bigloo/bigloo-2.9a.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/bigloo/bigloo-2.9a.ebuild,v 1.6 2007/06/27 06:53:18 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/bigloo/bigloo-2.9a.ebuild,v 1.7 2008/08/28 17:49:25 ulm Exp $
inherit elisp-common multilib
@@ -24,7 +24,9 @@ IUSE="emacs"
# fullbee"
src_compile() {
- use emacs && elisp-comp etc/*.el
+ if use emacs; then
+ elisp-compile etc/*.el || die "elisp-compile failed"
+ fi
# Bigloo doesn't use autoconf and consequently a lot of options used by econf give errors
# Manuel Serrano says: "Please, dont talk to me about autoconf. I simply dont want to hear about it..."
@@ -62,7 +64,7 @@ src_install () {
emake DESTDIR=${D} install || die "install failed"
if use emacs; then
- elisp-install ${PN} etc/*.el
+ elisp-install ${PN} etc/*.{el,elc} || die "elisp-install failed"
elisp-site-file-install "${FILESDIR}/${SITEFILE}"
fi
diff --git a/dev-scheme/bigloo/bigloo-3.0a_p2.ebuild b/dev-scheme/bigloo/bigloo-3.0a_p2.ebuild
index 966516e7d8d8..142887007975 100644
--- a/dev-scheme/bigloo/bigloo-3.0a_p2.ebuild
+++ b/dev-scheme/bigloo/bigloo-3.0a_p2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/bigloo/bigloo-3.0a_p2.ebuild,v 1.2 2007/06/20 15:03:52 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/bigloo/bigloo-3.0a_p2.ebuild,v 1.3 2008/08/28 17:49:25 ulm Exp $
inherit elisp-common multilib
@@ -24,7 +24,9 @@ IUSE="emacs"
# fullbee"
src_compile() {
- use emacs && elisp-comp etc/*.el
+ if use emacs; then
+ elisp-compile etc/*.el || die "elisp-compile failed"
+ fi
# Bigloo doesn't use autoconf and consequently a lot of options used by econf give errors
# Manuel Serrano says: "Please, dont talk to me about autoconf. I simply dont want to hear about it..."
@@ -62,7 +64,7 @@ src_install () {
emake DESTDIR=${D} install || die "install failed"
if use emacs; then
- elisp-install ${PN} etc/*.el
+ elisp-install ${PN} etc/*.{el,elc} || die "elisp-install failed"
elisp-site-file-install "${FILESDIR}/${SITEFILE}"
fi
diff --git a/dev-scheme/bigloo/bigloo-3.0b.ebuild b/dev-scheme/bigloo/bigloo-3.0b.ebuild
index 3ad564a9464b..0037462b8be9 100644
--- a/dev-scheme/bigloo/bigloo-3.0b.ebuild
+++ b/dev-scheme/bigloo/bigloo-3.0b.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/bigloo/bigloo-3.0b.ebuild,v 1.2 2007/09/11 15:32:44 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/bigloo/bigloo-3.0b.ebuild,v 1.3 2008/08/28 17:49:25 ulm Exp $
inherit elisp-common multilib
@@ -25,7 +25,9 @@ IUSE="emacs java"
# fullbee"
src_compile() {
- use emacs && elisp-comp etc/*.el
+ if use emacs; then
+ elisp-compile etc/*.el || die "elisp-compile failed"
+ fi
# Bigloo doesn't use autoconf and consequently a lot of options used by econf give errors
# Manuel Serrano says: "Please, dont talk to me about autoconf. I simply dont want to hear about it..."
@@ -67,7 +69,7 @@ src_install () {
emake -j1 DESTDIR=${D} install || die "install failed"
if use emacs; then
- elisp-install ${PN} etc/*.el
+ elisp-install ${PN} etc/*.{el,elc} || die "elisp-install failed"
elisp-site-file-install "${FILESDIR}/${SITEFILE}"
fi
diff --git a/dev-scheme/bigloo/bigloo-3.0b_p2.ebuild b/dev-scheme/bigloo/bigloo-3.0b_p2.ebuild
index 122ba3dafa8f..6bb34319dad8 100644
--- a/dev-scheme/bigloo/bigloo-3.0b_p2.ebuild
+++ b/dev-scheme/bigloo/bigloo-3.0b_p2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/bigloo/bigloo-3.0b_p2.ebuild,v 1.2 2007/09/26 14:55:49 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/bigloo/bigloo-3.0b_p2.ebuild,v 1.3 2008/08/28 17:49:25 ulm Exp $
inherit elisp-common multilib
@@ -25,7 +25,9 @@ IUSE="emacs java"
# fullbee"
src_compile() {
- use emacs && elisp-comp etc/*.el
+ if use emacs; then
+ elisp-compile etc/*.el || die "elisp-compile failed"
+ fi
# Bigloo doesn't use autoconf and consequently a lot of options used by econf give errors
# Manuel Serrano says: "Please, dont talk to me about autoconf. I simply dont want to hear about it..."
@@ -56,7 +58,7 @@ src_install () {
emake -j1 DESTDIR="${D}" install || die "install failed"
if use emacs; then
- elisp-install ${PN} etc/*.el
+ elisp-install ${PN} etc/*.{el,elc} || die "elisp-install failed"
elisp-site-file-install "${FILESDIR}/${SITEFILE}"
fi
diff --git a/dev-scheme/bigloo/bigloo-3.0c.ebuild b/dev-scheme/bigloo/bigloo-3.0c.ebuild
index b7afa589f7dc..f3a25f5ac660 100644
--- a/dev-scheme/bigloo/bigloo-3.0c.ebuild
+++ b/dev-scheme/bigloo/bigloo-3.0c.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/bigloo/bigloo-3.0c.ebuild,v 1.1 2007/12/03 16:40:25 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/bigloo/bigloo-3.0c.ebuild,v 1.2 2008/08/28 17:49:25 ulm Exp $
inherit elisp-common multilib
@@ -25,7 +25,9 @@ IUSE="emacs java"
# fullbee"
src_compile() {
- use emacs && elisp-comp etc/*.el
+ if use emacs; then
+ elisp-compile etc/*.el || die "elisp-compile failed"
+ fi
# Bigloo doesn't use autoconf and consequently a lot of options used by econf give errors
# Manuel Serrano says: "Please, dont talk to me about autoconf. I simply dont want to hear about it..."
@@ -56,7 +58,7 @@ src_install () {
emake -j1 DESTDIR="${D}" install || die "install failed"
if use emacs; then
- elisp-install ${PN} etc/*.el
+ elisp-install ${PN} etc/*.{el,elc} || die "elisp-install failed"
elisp-site-file-install "${FILESDIR}/${SITEFILE}"
fi
diff --git a/dev-scheme/bigloo/bigloo-3.0c_p4.ebuild b/dev-scheme/bigloo/bigloo-3.0c_p4.ebuild
index 28ddbedb6758..ebf948ab8340 100644
--- a/dev-scheme/bigloo/bigloo-3.0c_p4.ebuild
+++ b/dev-scheme/bigloo/bigloo-3.0c_p4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/bigloo/bigloo-3.0c_p4.ebuild,v 1.3 2008/04/28 18:05:41 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/bigloo/bigloo-3.0c_p4.ebuild,v 1.4 2008/08/28 17:49:25 ulm Exp $
inherit elisp-common multilib
@@ -27,7 +27,9 @@ IUSE="emacs java"
# fullbee"
src_compile() {
- use emacs && elisp-comp etc/*.el
+ if use emacs; then
+ elisp-compile etc/*.el || die "elisp-compile failed"
+ fi
# Bigloo doesn't use autoconf and consequently a lot of options used by econf give errors
# Manuel Serrano says: "Please, dont talk to me about autoconf. I simply dont want to hear about it..."
@@ -58,7 +60,7 @@ src_install () {
emake -j1 DESTDIR="${D}" install || die "install failed"
if use emacs; then
- elisp-install ${PN} etc/*.el
+ elisp-install ${PN} etc/*.{el,elc} || die "elisp-install failed"
elisp-site-file-install "${FILESDIR}/${SITEFILE}"
fi
diff --git a/dev-scheme/bigloo/bigloo-3.1a.ebuild b/dev-scheme/bigloo/bigloo-3.1a.ebuild
index 5b68761e168f..ae490fade49a 100644
--- a/dev-scheme/bigloo/bigloo-3.1a.ebuild
+++ b/dev-scheme/bigloo/bigloo-3.1a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/bigloo/bigloo-3.1a.ebuild,v 1.1 2008/06/03 10:12:53 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/bigloo/bigloo-3.1a.ebuild,v 1.2 2008/08/28 17:49:25 ulm Exp $
inherit elisp-common multilib
@@ -27,7 +27,9 @@ IUSE="emacs java"
# fullbee"
src_compile() {
- use emacs && elisp-comp etc/*.el
+ if use emacs; then
+ elisp-compile etc/*.el || die "elisp-compile failed"
+ fi
# Bigloo doesn't use autoconf and consequently a lot of options used by econf give errors
# Manuel Serrano says: "Please, dont talk to me about autoconf. I simply dont want to hear about it..."
@@ -58,7 +60,7 @@ src_install () {
emake -j1 DESTDIR="${D}" install || die "install failed"
if use emacs; then
- elisp-install ${PN} etc/*.el
+ elisp-install ${PN} etc/*.{el,elc} || die "elisp-install failed"
elisp-site-file-install "${FILESDIR}/${SITEFILE}"
fi