summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Ferri <mescalinum@gentoo.org>2009-05-10 13:17:04 +0000
committerFederico Ferri <mescalinum@gentoo.org>2009-05-10 13:17:04 +0000
commit312d4dd933e6fca5d76b76c8907c05ee0dc040d4 (patch)
tree814e0cbc575090b5c2070b290ba4fb0c88b09b28 /dev-tcltk/tcl3d
parentFix POSIX issue with test in configure.ac patch (diff)
downloadgentoo-2-312d4dd933e6fca5d76b76c8907c05ee0dc040d4.tar.gz
gentoo-2-312d4dd933e6fca5d76b76c8907c05ee0dc040d4.tar.bz2
gentoo-2-312d4dd933e6fca5d76b76c8907c05ee0dc040d4.zip
first ebuild for tcl3d
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-tcltk/tcl3d')
-rw-r--r--dev-tcltk/tcl3d/ChangeLog10
-rw-r--r--dev-tcltk/tcl3d/metadata.xml25
-rw-r--r--dev-tcltk/tcl3d/tcl3d-0.4.0.ebuild58
3 files changed, 93 insertions, 0 deletions
diff --git a/dev-tcltk/tcl3d/ChangeLog b/dev-tcltk/tcl3d/ChangeLog
new file mode 100644
index 000000000000..67fa9f208c49
--- /dev/null
+++ b/dev-tcltk/tcl3d/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-tcltk/tcl3d
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tcl3d/ChangeLog,v 1.1 2009/05/10 13:17:04 mescalinum Exp $
+
+*tcl3d-0.4.0 (10 May 2009)
+
+ 10 May 2009; Federico Ferri <mescalinum@gentoo.org> +metadata.xml,
+ +tcl3d-0.4.0.ebuild:
+ first ebuild for tcl3d
+
diff --git a/dev-tcltk/tcl3d/metadata.xml b/dev-tcltk/tcl3d/metadata.xml
new file mode 100644
index 000000000000..ace90fa62a6c
--- /dev/null
+++ b/dev-tcltk/tcl3d/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>tcltk</herd>
+<maintainer>
+ <email>mescalinum@gentoo.org</email>
+</maintainer>
+<longdescription>
+Tcl3D offers the 3D functionality of OpenGL and other 3D libraries at the Tcl scripting level.
+The Tcl3D package currently consists of the following modules:
+
+Tcl3D core module
+tcl3dOgl Enhanced Togl widget, a Tk widget for displaying OpenGL content.
+ Wrapper for core OpenGL functionality (GL Version 3.0, GLU Version 1.2) and OpenGL extensions.
+ Tcl3D utility library: Math functions, standard shapes, stop watch, demo support.
+
+Tcl3D optional modules
+tcl3dCg Wrapper for NVidia's Cg shading language. *
+tcl3dSDL Wrapper for the Simple DirectMedia Library.
+tcl3dFTGL Wrapper for the OpenGL Font Rendering Library.
+tcl3dGl2ps Wrapper for the OpenGL To Postscript library. *
+tcl3dOde Wrapper for the Open Dynamics Engine.
+tcl3dGauges Tcl3D package for displaying gauges.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-tcltk/tcl3d/tcl3d-0.4.0.ebuild b/dev-tcltk/tcl3d/tcl3d-0.4.0.ebuild
new file mode 100644
index 000000000000..7dbf176a16b5
--- /dev/null
+++ b/dev-tcltk/tcl3d/tcl3d-0.4.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tcl3d/tcl3d-0.4.0.ebuild,v 1.1 2009/05/10 13:17:04 mescalinum Exp $
+
+EAPI="2"
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Tcl bindings to OpenGL and other 3D libraries"
+HOMEPAGE="http://www.tcl3d.org"
+SRC_URI="http://www.tcl3d.org/download/${P}.distrib/${PN}-src-${PV}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug"
+
+RDEPEND="virtual/opengl
+ dev-lang/tk
+ dev-lang/tcl
+ media-libs/libsdl
+ media-libs/ftgl
+ dev-games/ode"
+DEPEND="${RDEPEND}
+ >=dev-lang/swig-1.3.19"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ TCL_VERSION=( $(echo 'puts [info tclversion]' | tclsh | tr '.' ' ') )
+ einfo "Configuring for Tcl ${TCL_VERSION[0]}.${TCL_VERSION[1]}"
+ sed -i \
+ -e 's:^\(TCLMAJOR\) *=\(.*\)$:\1 = '${TCL_VERSION[0]}':' \
+ -e 's:^\(TCLMINOR\) *=\(.*\)$:\1 = '${TCL_VERSION[1]}':' \
+ config_Linux*
+
+ # fix libSDL link
+ sed -i \
+ -e 's:-lSDL-1\.2:-lSDL:g' \
+ tcl3dSDL/Makefile
+}
+
+src_compile() {
+ append-flags -mieee-fp -ffloat-store -fPIC
+ if use debug; then
+ append-flags -g
+ filter-flags -O?
+ else
+ append-flags -DNDEBUG
+ fi
+ gmake INSTDIR="/usr" OPT="${CFLAGS}" CC="$(tc-getCC) -c" \
+ CXX="$(tc-getCXX) -c" LD="$(tc-getLD)" \
+ WRAP_FTGL=1 WRAP_SDL=1 WRAP_GL2PS=0 WRAP_ODE=1 || die "gmake failed"
+}
+
+src_install() {
+ gmake INSTDIR="${D}/usr" DESTDIR="${D}" install || die "gmake install failed"
+}