summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-07-27 23:44:11 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-07-27 23:44:11 +0000
commitd16cce22886d35d01088a0bfc4600b7aca4affa2 (patch)
tree66ec53878787b38189709d81bf1831f6e14b89b3 /dev-tcltk/tclcl/tclcl-1.15.ebuild
parentAdd ~amd64 closes bug #57764 (Manifest recommit) (diff)
downloadgentoo-2-d16cce22886d35d01088a0bfc4600b7aca4affa2.tar.gz
gentoo-2-d16cce22886d35d01088a0bfc4600b7aca4affa2.tar.bz2
gentoo-2-d16cce22886d35d01088a0bfc4600b7aca4affa2.zip
fix bug #57294.
Diffstat (limited to 'dev-tcltk/tclcl/tclcl-1.15.ebuild')
-rw-r--r--dev-tcltk/tclcl/tclcl-1.15.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/dev-tcltk/tclcl/tclcl-1.15.ebuild b/dev-tcltk/tclcl/tclcl-1.15.ebuild
index 17d619009907..b1746db32171 100644
--- a/dev-tcltk/tclcl/tclcl-1.15.ebuild
+++ b/dev-tcltk/tclcl/tclcl-1.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclcl/tclcl-1.15.ebuild,v 1.5 2004/06/25 02:08:09 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclcl/tclcl-1.15.ebuild,v 1.6 2004/07/27 23:44:11 robbat2 Exp $
DESCRIPTION="Tcl/C++ interface library"
SF_PN="otcl-tclcl"
@@ -16,9 +16,14 @@ DEPEND=">=dev-lang/tcl-8.3.2
>=dev-tcltk/otcl-1.0.8"
src_compile() {
- econf || die
- sed 's|$(LIBRARY_TCL)/http/http.tcl|$(LIBRARY_TCL)/http2.4/http.tcl|g' -i Makefile
- emake || die
+ local tclv tkv
+ tclv=$(grep TCL_VER /usr/include/tcl.h | sed 's/^.*"\(.*\)".*/\1/')
+ tkv=$(grep TK_VER /usr/include/tk.h | sed 's/^.*"\(.*\)".*/\1/')
+ local myconf="--with-tcl-ver=${tclv} --with-tk-ver=${tkv}"
+ econf ${myconf} || die "econf failed"
+ sed 's|$(LIBRARY_TCL)/http.*/http.tcl|$(LIBRARY_TCL)/http2.4/http.tcl|g' \
+ -i Makefile || die "sed failed"
+ emake || die "emake failed"
}
src_install() {