summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-04-02 09:13:19 +0000
committerJustin Lecher <jlec@gentoo.org>2010-04-02 09:13:19 +0000
commit9a1431dd61199ede48a2774b3b6299e7eab16c90 (patch)
tree490c84e50f96665f95ef239b7326625ded32e3ef /dev-tcltk
parentFix manifest (diff)
downloadgentoo-2-9a1431dd61199ede48a2774b3b6299e7eab16c90.tar.gz
gentoo-2-9a1431dd61199ede48a2774b3b6299e7eab16c90.tar.bz2
gentoo-2-9a1431dd61199ede48a2774b3b6299e7eab16c90.zip
Imported from prefix overlay
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/tls/ChangeLog9
-rw-r--r--dev-tcltk/tls/tls-1.6-r2.ebuild44
2 files changed, 51 insertions, 2 deletions
diff --git a/dev-tcltk/tls/ChangeLog b/dev-tcltk/tls/ChangeLog
index 4270fdb810d3..cc7d2df356de 100644
--- a/dev-tcltk/tls/ChangeLog
+++ b/dev-tcltk/tls/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-tcltk/tls
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tls/ChangeLog,v 1.26 2009/11/16 19:57:19 mescalinum Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tls/ChangeLog,v 1.27 2010/04/02 09:13:19 jlec Exp $
+
+*tls-1.6-r2 (02 Apr 2010)
+
+ 02 Apr 2010; Justin Lecher <jlec@gentoo.org> +tls-1.6-r2.ebuild:
+ Imported from prefix overlay
*tls-1.6-r1 (16 Nov 2009)
diff --git a/dev-tcltk/tls/tls-1.6-r2.ebuild b/dev-tcltk/tls/tls-1.6-r2.ebuild
new file mode 100644
index 000000000000..7f9b32bf317b
--- /dev/null
+++ b/dev-tcltk/tls/tls-1.6-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tls/tls-1.6-r2.ebuild,v 1.1 2010/04/02 09:13:19 jlec Exp $
+
+EAPI="3"
+
+inherit eutils multilib
+
+MY_P="${PN}${PV}"
+DESCRIPTION="TLS OpenSSL extension to Tcl."
+HOMEPAGE="http://tls.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tls/${MY_P}-src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="tk"
+
+RESTRICT="test"
+
+DEPEND=">=dev-lang/tcl-8.3.3
+ dev-libs/openssl
+ tk? ( >=dev-lang/tk-8.3.3 )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ econf \
+ --with-ssl-dir="${EPREFIX}"/usr \
+ --with-tcl="${EPREFIX}"/usr/$(get_libdir) \
+ || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog README.txt
+ dohtml tls.htm
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ # this is ugly, but fixing the makefile mess is even worse
+ local loc=usr/$(get_libdir)/tls1.6/libtls1.6.dylib
+ install_name_tool -id "${EPREFIX}"/${loc} "${ED}"/${loc} || die
+ fi
+}