summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-08-15 17:15:10 +0000
committerJustin Lecher <jlec@gentoo.org>2011-08-15 17:15:10 +0000
commitadb899d4363b6267d6daf4b2d9fbb4bdb4a64573 (patch)
tree84e952de192f2e3dfe2c78da38fbe6cf915d2b69 /dev-tcltk
parentDisabling dmalloc support in samba, it crashes due to re-definition of many s... (diff)
downloadgentoo-2-adb899d4363b6267d6daf4b2d9fbb4bdb4a64573.tar.gz
gentoo-2-adb899d4363b6267d6daf4b2d9fbb4bdb4a64573.tar.bz2
gentoo-2-adb899d4363b6267d6daf4b2d9fbb4bdb4a64573.zip
Make multilib compatible, #378991; respect CFLAGS
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/togl/ChangeLog8
-rw-r--r--dev-tcltk/togl/metadata.xml4
-rw-r--r--dev-tcltk/togl/togl-2.0-r1.ebuild7
-rw-r--r--dev-tcltk/togl/togl-2.0-r2.ebuild45
4 files changed, 58 insertions, 6 deletions
diff --git a/dev-tcltk/togl/ChangeLog b/dev-tcltk/togl/ChangeLog
index 496bca982253..10c167e8f1c9 100644
--- a/dev-tcltk/togl/ChangeLog
+++ b/dev-tcltk/togl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-tcltk/togl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/togl/ChangeLog,v 1.18 2011/07/11 15:05:08 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/togl/ChangeLog,v 1.19 2011/08/15 17:15:10 jlec Exp $
+
+*togl-2.0-r2 (15 Aug 2011)
+
+ 15 Aug 2011; Justin Lecher <jlec@gentoo.org> togl-2.0-r1.ebuild,
+ +togl-2.0-r2.ebuild, metadata.xml:
+ Make multilib compatible, #378991; respect CFLAGS
11 Jul 2011; Matt Turner <mattst88@gentoo.org> togl-2.0-r1.ebuild:
Added ~mips, bug 298612
diff --git a/dev-tcltk/togl/metadata.xml b/dev-tcltk/togl/metadata.xml
index 9282f5a6fdd3..ef797583d3d2 100644
--- a/dev-tcltk/togl/metadata.xml
+++ b/dev-tcltk/togl/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>tcltk</herd>
-<longdescription>
+ <herd>tcltk</herd>
+ <longdescription>
Togl is a Tk widget for OpenGL rendering. Togl was originally based on
OGLTK, written by Benjamin Bederson at the University of New Mexico. Togl's
main features are:
diff --git a/dev-tcltk/togl/togl-2.0-r1.ebuild b/dev-tcltk/togl/togl-2.0-r1.ebuild
index 26d2e13c06d2..7a7a290138ea 100644
--- a/dev-tcltk/togl/togl-2.0-r1.ebuild
+++ b/dev-tcltk/togl/togl-2.0-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/togl/togl-2.0-r1.ebuild,v 1.15 2011/07/11 15:05:08 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/togl/togl-2.0-r1.ebuild,v 1.16 2011/08/15 17:15:10 jlec Exp $
-EAPI="2"
+EAPI=2
MY_P="Togl${PV}"
@@ -15,7 +15,8 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
IUSE="debug +threads"
-RDEPEND="dev-lang/tk
+RDEPEND="
+ dev-lang/tk
virtual/opengl"
DEPEND="${RDEPEND}"
diff --git a/dev-tcltk/togl/togl-2.0-r2.ebuild b/dev-tcltk/togl/togl-2.0-r2.ebuild
new file mode 100644
index 000000000000..6891ab63d1b4
--- /dev/null
+++ b/dev-tcltk/togl/togl-2.0-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/togl/togl-2.0-r2.ebuild,v 1.1 2011/08/15 17:15:10 jlec Exp $
+
+EAPI=4
+
+MY_P="Togl${PV}"
+
+DESCRIPTION="A Tk widget for OpenGL rendering"
+HOMEPAGE="http://togl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}-src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="debug +threads"
+
+RDEPEND="
+ dev-lang/tk
+ virtual/opengl"
+DEPEND="${RDEPEND}"
+
+# tests directory is missing
+RESTRICT="test"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ sed \
+ -e 's:-fomit-frame-pointer::g' \
+ -e 's:-O2::g' \
+ -i configure || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug symbols) \
+ $(use_enable threads)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "failed to install"
+ dohtml doc/* || die "no html"
+ dodoc README* || die "no README"
+}