summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-10-28 11:45:21 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-10-28 11:45:21 +0000
commit6b6257a39d8c3f8d1e26e945b171ea53ff466bea (patch)
treee431e907d24d20b3879647a2ed750ff6ddb459f0 /dev-tex/dot2tex/dot2tex-2.8.7.ebuild
parentExplicitly block zaptel prior to unmasking. (diff)
downloadgentoo-2-6b6257a39d8c3f8d1e26e945b171ea53ff466bea.tar.gz
gentoo-2-6b6257a39d8c3f8d1e26e945b171ea53ff466bea.tar.bz2
gentoo-2-6b6257a39d8c3f8d1e26e945b171ea53ff466bea.zip
version bump
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'dev-tex/dot2tex/dot2tex-2.8.7.ebuild')
-rw-r--r--dev-tex/dot2tex/dot2tex-2.8.7.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-tex/dot2tex/dot2tex-2.8.7.ebuild b/dev-tex/dot2tex/dot2tex-2.8.7.ebuild
new file mode 100644
index 000000000000..f387d73c5d90
--- /dev/null
+++ b/dev-tex/dot2tex/dot2tex-2.8.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/dot2tex/dot2tex-2.8.7.ebuild,v 1.1 2009/10/28 11:45:21 aballier Exp $
+
+inherit distutils
+
+DESCRIPTION="A Graphviz to LaTeX converter"
+HOMEPAGE="http://www.fauskes.net/code/dot2tex/"
+SRC_URI="http://dot2tex.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="doc examples"
+
+DEPEND=""
+RDEPEND=">=dev-python/pyparsing-1.4.8
+ media-gfx/pydot
+ media-gfx/graphviz"
+
+DOCS="changelog.txt"
+
+src_install() {
+ distutils_src_install
+ if use doc; then
+ dohtml -r doc/*
+ dodoc doc/usage.{txt,pdf}
+ fi
+ if use examples; then
+ insinto "/usr/share/doc/${PF}/examples"
+ doins examples/*
+ fi
+}