summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-11-29 14:04:54 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-11-29 14:04:54 +0000
commitab8188ff1ab8bdaca0327cde51bff94604d7fb02 (patch)
tree6f425b7d6ca7a1b286e6cd2aa308a52cbb444cf3 /dev-tex/mplib
parentversion bump (diff)
downloadgentoo-2-ab8188ff1ab8bdaca0327cde51bff94604d7fb02.tar.gz
gentoo-2-ab8188ff1ab8bdaca0327cde51bff94604d7fb02.tar.bz2
gentoo-2-ab8188ff1ab8bdaca0327cde51bff94604d7fb02.zip
version bump
(Portage version: 2.2_rc16/cvs/Linux 2.6.27.7 x86_64)
Diffstat (limited to 'dev-tex/mplib')
-rw-r--r--dev-tex/mplib/ChangeLog7
-rw-r--r--dev-tex/mplib/mplib-1.110.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-tex/mplib/ChangeLog b/dev-tex/mplib/ChangeLog
index 1fe65fdca612..5840bf8453cc 100644
--- a/dev-tex/mplib/ChangeLog
+++ b/dev-tex/mplib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-tex/mplib
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/mplib/ChangeLog,v 1.7 2008/10/05 19:51:16 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/mplib/ChangeLog,v 1.8 2008/11/29 14:04:54 aballier Exp $
+
+*mplib-1.110 (29 Nov 2008)
+
+ 29 Nov 2008; Alexis Ballier <aballier@gentoo.org> +mplib-1.110.ebuild:
+ version bump
05 Oct 2008; Jeroen Roovers <jer@gentoo.org> mplib-1.091.ebuild:
Marked ~hppa (bug #237202).
diff --git a/dev-tex/mplib/mplib-1.110.ebuild b/dev-tex/mplib/mplib-1.110.ebuild
new file mode 100644
index 000000000000..6787581b2f68
--- /dev/null
+++ b/dev-tex/mplib/mplib-1.110.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/mplib/mplib-1.110.ebuild,v 1.1 2008/11/29 14:04:54 aballier Exp $
+
+EAPI=1
+
+inherit libtool
+
+DESCRIPTION="New, revamped version of the MetaPost interpreter"
+HOMEPAGE="http://foundry.supelec.fr/projects/metapost"
+SRC_URI="http://foundry.supelec.fr/frs/download.php/696/${PN}-beta-${PV}-src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+# We enalbe lua by default because it will be needed by luatex
+IUSE="+lua"
+
+RDEPEND="virtual/tex-base
+ lua? ( dev-lang/lua )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}-beta-${PV}/src/texk/web2c/mpdir
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ elibtoolize
+}
+
+src_compile() {
+ econf $(use_enable lua)
+ # parallel make fails from time to time... needs to be fixed
+ emake KPSESRCDIR=/usr/include/kpathsea KPSELIB=-lkpathsea -j1 || die "failed to build mplib"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ mv "${D}/usr/bin/mpost" "${D}/usr/bin/mpost-${P}" || die "failed to rename mpost"
+ dodoc "${WORKDIR}/${PN}-beta-${PV}/CHANGES" "${WORKDIR}/${PN}-beta-${PV}/README"
+}