summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-03-15 10:17:30 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-03-15 10:17:30 +0000
commit57c6b11868d5258a4619157a670d3c03f93b457e (patch)
tree1c89a16899912d2f4560da8ca947208487ec1f61 /dev-tex/pgf
parentalpha stable wrt bug #495552; Drop old. (diff)
downloadgentoo-2-57c6b11868d5258a4619157a670d3c03f93b457e.tar.gz
gentoo-2-57c6b11868d5258a4619157a670d3c03f93b457e.tar.bz2
gentoo-2-57c6b11868d5258a4619157a670d3c03f93b457e.zip
Version bump, bug #497436. Fixes bugs #406783 and #399087. Symlink docs from the texmf tree so that texdoc finds it, bug #441874.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-tex/pgf')
-rw-r--r--dev-tex/pgf/ChangeLog10
-rw-r--r--dev-tex/pgf/pgf-3.0.0.ebuild39
2 files changed, 47 insertions, 2 deletions
diff --git a/dev-tex/pgf/ChangeLog b/dev-tex/pgf/ChangeLog
index 65f417f971bd..dfd011bb0fed 100644
--- a/dev-tex/pgf/ChangeLog
+++ b/dev-tex/pgf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-tex/pgf
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/pgf/ChangeLog,v 1.65 2012/05/09 16:27:02 aballier Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/pgf/ChangeLog,v 1.66 2014/03/15 10:17:30 aballier Exp $
+
+*pgf-3.0.0 (15 Mar 2014)
+
+ 15 Mar 2014; Alexis Ballier <aballier@gentoo.org> +pgf-3.0.0.ebuild:
+ Version bump, bug #497436. Fixes bugs #406783 and #399087. Symlink docs from
+ the texmf tree so that texdoc finds it, bug #441874.
09 May 2012; Alexis Ballier <aballier@gentoo.org> pgf-2.10.ebuild:
keyword ~amd64-fbsd
diff --git a/dev-tex/pgf/pgf-3.0.0.ebuild b/dev-tex/pgf/pgf-3.0.0.ebuild
new file mode 100644
index 000000000000..45c188fe38c8
--- /dev/null
+++ b/dev-tex/pgf/pgf-3.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/pgf/pgf-3.0.0.ebuild,v 1.1 2014/03/15 10:17:30 aballier Exp $
+
+inherit latex-package
+
+DESCRIPTION="pgf -- The TeX Portable Graphic Format"
+HOMEPAGE="http://sourceforge.net/projects/pgf"
+SRC_URI="mirror://sourceforge/pgf/${PN}_${PV}.tds.zip"
+
+LICENSE="GPL-2 LPPL-1.3c FDL-1.2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc source"
+
+RDEPEND="dev-texlive/texlive-latexrecommended
+ >=dev-tex/xcolor-2.11"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_install() {
+ insinto ${TEXMF}
+ doins -r tex || die
+
+ if use source ; then
+ doins -r source || die
+ fi
+
+ cd "${S}/doc/generic/pgf"
+ dodoc AUTHORS ChangeLog README || die
+ if use doc ; then
+ insinto /usr/share/doc/${PF}/texdoc
+ doins pgfmanual.pdf || die
+ doins -r images macros text-en version-* || die
+ dosym /usr/share/doc/${PF}/texdoc ${TEXMF}/doc/latex/${PN} || die
+ fi
+}